[Solved] P1 not booting at higher source voltages (regulated)

I’ve built a custom P1 board and it’s mostly working great. Over USB its solid, and when connected to a DC source under 10.5V it boots up fine. My project is to be powered with a 12V battery though.

At 12V the system never boots up. It just restarts coming online over and over again in my console.

I’m using a fixed 3.3V voltage regulator with bench DC supply.

Any thoughts?

A (partial) schematic would be helpful. As a start, questions I’d have are:
a) which regulator are you using
b) voltages as measured before and after regulator
c) regulator output connects directly to P1 or any other components in between?
d) did you measure current draw?


Thanks for the quick response!

A) LDL1117 - input voltages up to 18V and 1.2A current.

B) Precisely 12V on the input of the voltage regulator, 3.27V on the output, and testing a cap right by the P1, also reading 3.27V. Quite a few other components on the board but drawing well below limits.

D) Current bounces between 65-210mA when in this un-bootable state at 12V. When lowering voltage to 10.5V where it will properly boot up, current draw is at 155mA.

Partial schem attached:

@LoneWolf367, seems odd. The fact that the P1 is booting at an input of 10.5v vs 12v indicates a possible regulation issue that you would need to see on a scope, not just by measuring with a DMM. What does the P1 RST circuit look like?

1 Like

At 12V the regulator has ticks in voltage drop. Upon further testing, after being on for several minutes at 8.5-10.5V the system crashes and same problem begins at the voltage regulator. The regulator is not particularly hot to the touch.

The higher the voltage, the shorter the period of time before it crashes. The problem seems to stop at <8.4V.

Reset and setup button schem:


10.5V source

12V source

Can you post a photo of area on the PCB where the regulator is.
Thus far nothing jumps out schematic wise. For now, what I would try is using a different regulator and tack in place where the current one is and see if things change.

The regulator is on a separate PCB from the P1. It has some headers on this board that connect to my P1 board.

Looks like I’m looking for a different regulator. Thanks for the suggestions.

Tried several different things:

1.) Breadboarded up a LM317 adjustable voltage regulator and supplied power to the board. Rock solid.

2.) Flowed my LDL1117 off the board to isolate it. added a 47uF aluminum cap across the input and gnd. Results were the same mounted to the board at 12V.

Would be great to gain any insight into what might be happening.

My guess is that the LDL1117 is overheating and shutting down (see section 6.1 of datasheet). When it shuts down it cools off, then it turns on again. That’s probably what the spikes are from.
If you used an LM317 in a TO220 or similar package, it has a better thermal resistance than the SOT223.
The LDL1117 is dissipating 1.1W at 10.5V in. That’s a lot on a small PCB without some metal (can’t really tell by picture). I think this is also why the P1 lasts longer at lower voltages… less dissipation.

Try blowing air or attach a heat sink to the LDL1117 and see if the problem goes away.

2 questions.
#1) Is this reading on the 3.3v output of the regulator or the input side ?
#2) if you power it with 10v and allow it to boot up, then slowly ramp the power up to 12v does it stop working?

Attempted putting a pretty heavy flow of cold air over the chip. The behavior of blipping off and on begins near instantly.


  1. The 3.3V is output of the regulator. For my scope readouts, channel 1 is the 3.3V output of the regulator, channel 2 is my 10-12V input.
  2. Starting at 10V slowly turning up the power, the system fails by around 11V.

@LoneWolf367, thinking about the LM317 that works… Was it connected to the same pads of the LD1117?
I wonder if you have a connection problem.
I would still add some copper or a heatsink to the SOT223, especially if this HW goes into an enclosure.

Since it fails after starting at 10v and even when you increase the voltage it then fails shows its not a startup inrush issue.

Try this, Get yourself any generic cans of air, like these from you local store.

With the unit off, turn the can upside down and put the red tube over the regulator. Then !!! SLOWLY !!! pull on the handle until the liquid starts to drip out onto the regulator. Do this for a bit until the part is white showing that its really cold. Then set your PS to say 11 or 12v and turn it on and see if it boots.


Can of electronics duster did the trick. Was able to turn up over 12V and as long as keeping cold it stays up and running. Looks like this regulator isn’t up for the task at hand.

Thank you all for helping debug this. Great community here!

Marking as solved.

@LoneWolf367, you may want to consider a switching regulator instead of an LDO for that large a drop. I often use these RECOM units on my PCB designs.


1 Like

I like those Recom devices. I also keep a handful of Pololu devices around when I need to drop a ton of volts and have little room left. https://www.pololu.com/product/2842


Yes, I also use the Recom 78x switching regulators and have been happy with them.

1 Like

Last year we needed a very high efficient low noise PS module. Ran a bunch of tests on several modules, including the Recom. The Recom ranked second to last in the tests out of 8 modules in the most noise category. The 2 that were the best performance wise, I.E. low noise, and high efficient were these.

#1) OKL-T/1-W12N-C
#2) OKR-T/1.5-W12-C

I have used #2 in many products over the years and never had one failure. After this testing I have switched to #1, mainly because its much smaller.