[SOLVED] I am receiving wrong firmware from Particle Dev


I have wierd problem. I use Particle Dev as a coding platform, when I click a “compile” button to get the binary firmware for my photons (I upload them manually - local cloud), I get a firmware which has 169kb and contain similar data as Photon’s system firmware. After flashing this to Photon, the firmware sometimes works as supposed, but more ofter it ends by breathing magenta and I have reflash the system firmware.
I dont understand why the cloud compiler sends me this?

Contents of the firmware I get from the Cloud compiler:

Thanks for help in advance


@dfarny, did you select one of your Photons as the target? If nothing is selected, it will compile for a Core.

I selected a photon which was offline… After changing the selection to online photon with 0.4.7 firmware, it compiles normally. Maybe the cloud tried to update system firmware to new version this way…


@dfarny, I don’t believe that DEV will generate or upated any system parts (like the IDE). It will always compile against the latest version. That, however, doesn’t explain your situation.

@kennethlimcp, any guidance?

Yes, it is definitely unexpected behaviour. If there is someone willing to examine this situation, I can send details. Another wierd thing is that the Photon I initially targeted is a wierd one which is offline, but cloud shows it online all the time.

@dfarny yeah sadly for now only Build allows the system update to kick in.