[solved] How to upgrade and setup my Beta Electron?

After following the instructions provided, I am getting an error message saying that

Bummer. Setup was unsuccessful

Here is a video that shows the flashing LED on the electron.

Can someone please guide me, where I could be going wrong.

Are you a beta electron user or kickstarter?

Hey there,

Based on the hardware in your video, you’ve got an Electron beta unit. The Electron does not seem to be running the default factory code, which is expected of the Electron beta units.

There are instructions available for updating your beta hardware to the latest firmware in the communications that were sent to you or your company representative along with your beta hardware. In the meantime, you can follow these instructions to install the latest version of system and user firmware on your device.

  • Plug the Electron into your computer using a USB cable
  • Put your Electron into DFU mode
  • Type the following commands using the Particle CLI
  • npm update -g particle-cli
  • particle update
  • particle flash --usb tinker
  • particle keys server
    (this makes sure your device has the public cloud key, UDP on production by default)

You should then be able to follow the online prompts at setup.particle.io to configure your device.

1 Like

Unable to flash the device with usb tinker, below is the message I get.

attempting to flash firmware to your device usb
Flash device failed
I didn't recognize that device name or ID, try opening https://api.particle.io/v1/devices?access_token=10179a4265f575b4103ea51b6db2d7edd691XXXX

When I check the url, there is no electron in the list of devices provided.
How do I add it to this list ? the mobile app to add the electron isn’t working (I get a blank screen when I try to add an electron).

PS: Currently the electron is just flashing green (for more than an hr)

What OS are you on?
If Windows, you need to use zadig to install the libusbK drivers.

Hey @Pravi – there was a typo in my instructions which I’ve since corrected. The correct command should read:

particle flash --usb tinker

The device is flashing green because it is trying to connect to the cellular tower. It will not be successful until you go through the setup process at setup.particle.io.

Dear Will,

Followed your commands using Particle CLI and got a message saying “Flash success”.

I have been to https://setup.particle.io, where I activated the sim, followed the instructions and got the below message

Bummer. Setup was unsuccessful

The Electron still flashes green, I also noticed that it did flash cyan few times (for short periods) but never breathing cyan.

Interestingly, I noticed that my usage was 0.21MB since feb 10th.

I went through the troubleshooting guide and I can confirm that there is decent 3G & mobile reception in the area (as you can see on the mobile screen in picture).

Is there anything else I need to look into.

@ScruffR, I am on a mac

@Pravi setup will not be successful until your device is breathing cyan (connected to the Cloud). Can you PM me your ICCID? I will check to see if there are any issues with your SIM card.

I checked the SIM that you sent to me, and it’s in the active state in our beta unit collection so it should not be having any problems. The device can take several minutes to connect to the cell tower–if you’ve seen it flash cyan that tells me that you do have service in your area. Because you have a beta Electron, it is possible that your device is missing the server keys that it needs to connect to our production device service. Try the following steps from our v048 release notes in the beta category:

##1. Upgrade your CLI/Electron Firmware

First things first, please upgrade to the most recent version of the Particle CLI (v1.8.22), which includes all of the most recent firmware binaries. Before you flash the new firmware, you’re going to need the UDP Public Server Key, which is different from the TCP Public Key which is already on your Electron.

1. First, download the UDP Public Key here:

2. Next, plug your Electron in over USB, put it into DFU mode, and type the following into your terminal, which will program your device with the new UDP Public Key:

dfu-util -d 2b04:d00a -a 1 -s 3298 -D ~/Downloads/server-public-key.udp.particle.io.der

Today is a National Holiday in the US, so our team is off work. Sorry for the slower than usual reply.

Thanks @will, Electron is now breathing cyan.

Fantastic. With the UDP key in place and the device breathing cyan you should be able to go through the setup process successfully.

@will I hope you don’t mind I edited your post above to add the simplified version of downloading the UDP server key. No need to download the key either.

  • particle keys server
    (this makes sure your device has the public cloud key, UDP on production by default)

thanks buddy!

Hey everyone, I tried these steps and I think I “bricked” an Electron Beta because it is now breathing magenta. Any ideas how to get it out of safe mode?

Don’t worry, it’s not bricked.

If you put it into DFU mode, you should be able to type the following commands to get to factory conditions:

particle update
particle flash --usb tinker

Thanks @will. I was able to get it breathing cyan again, but the Tinker app cannot seem to find it. Any other suggestions?

Hi @squeakywheel This is a confirmed issue, and we’ll be looking into this come tomorrow morning… since most everyone is off on the weekend :smile:

Awesome! thanks for the reply!

@squeakywheel just wanted to update you on the Particle App issue. We have located and resolved an issue that was preventing the app from detecting your Electron’s online status. If you refresh your devices on the Particle App, you should see your Electron online now and be able to control it with Tinker.

@BDub Thanks for the reply. I refreshed the Tinker App, logged out, logged back in and didn’t find the Electron listed. I also tried setting up the Electron again via setup.particle.io and via the iOS app without much luck.

Should I update the firmware on the Electron?