[SOLVED] Function calls to our Photon firmware via Particle API suddenly stopped working

Hi everyone.

As of last night, it seems that our Photons have been unable to connect to the Particle API or accept calls to firmware functions via the Particle API. Normally we interact with our devices using the following POST request: https://api.particle.io/v1/devices/<device_id>/motiEvent/?access_token=<access_token> where <device_id> and <access_token> are replaced by a specific device id and our access token respectively. In the past, we could expect a valid and rapid response. As of last night, POST requests to this URL will instead return the following to our server logs:

This call is no longer working, but calling the API for a status of our devices show that they are indeed connected and have the ‘motiEvent’ function accessible, which we are calling via the Particle API:

Has anybody experienced a similar problem? Our code base did not change over the last few days, so I am unsure what changed to cause this to stop working all of a sudden.

I appreciate any help.


Steven Mazliach
Software Developer

Have you tried calling the function manually to see if that makes any difference? You can use Dev, the CLI, my page, or a method of your own to call them.

I made calls to the function manually using the Postman app, and it still failed to connect, responding with a timeout error as well. I have used Postman in previous days to test this, and it has always worked up til now.

It seems that we have solved the issue. There was a problem with a single line of code in javascript for our application’s API that was called by the motiEvent function, which suddenly stopped working and caused a delay in response.