[SOLVED] Can Only Flash Tinker [OTA upgrade]

I can only flash tinker via the USB. If I flash through web I get a flashing magenta LED. I have tested several photons and all have the same issue. I have tested them with code I know works on a photon as well, e.g BLINK AN LED. My current devices with custom firmware that are flashed seem fine. I have tried reflashing a working device with its same firmware and it goes from working (breathing cyan) pre-reflash to flashing magenta (post-reflash)

Never mind. It looks like the OTA was just really slow for some reason.

That reason is probably the automated firmware update. If you click on your device in the devices tab, you’ll notice that you can pick a version. Once a newer version comes out, it will default to the latest. Doing an OTA firmware upgrade will take significantly longer than a normal user application, since it’s a lot more code. Just give it some time, and it should work itself out.
If, for whatever reason, the OTA failed, and it remains breathing magenta, simply try again, and it’ll try and fix itself. If you want to speed up the process, and minimize the risk of failure, hook the photon up to the CLI in DFU mode, and execute particle update after you’ve updated the CLI to the latest version by using sudo npm update -g particle-cli.