Solid cyan light and unresponsive [solved]

Hi, I’ve been developing some firmware for a few days now, and everything has been going great.

All of a sudden, now when I flash my firmware to a spark, the flash is successful, then after WiFi connection, the LED changes from flashing green to solid cyan. It stays solid. The spark is then completely unresponsive from the command line and web interfaces. If I perform a factory reset everything returns to normal (until I load my firmware again). I tried loading my firmware on a different spark and the same thing happened, so I think it’s my code.

The web and CLI interfaces report no errors during compilation or flashing, so where could the problem be?

There are some compiled binary which will give rise to issue and the error is not caught during compilation. It’s more like a bug in the OTA mechanism but for minority code.

You can attempt to change your code slightly and test again.

Sorry for the inconvenience for now :wink:

The code is available here, and hopefully can be flashed and this issue fixed by a dev

Is there a more formal place to file a bug report?

Bump here. Would be nice to know how to use my for my program? Or at least what is wrong with my program and how to fix it?


It seems like you are doing quite a chuck in the functions and the loop() is basically doing nothing.

You might want to reduce the task in the functions running and see how things go?

Also, i presume the program is running fine but you are unable to flash it via OTA. Is that right?

OK. I found the problem.
I am using the SparkIntervalTimer library which uses hardware timers. These thus use interrupts. Interrupt functions cannot call delay() and I was doing that.

Please mark as solved!

1 Like