Sleep Current som B523

We are trying to measure sleep current in 2.0.0-rc using the following code:

SystemSleepConfiguration config;

config.mode(SystemSleepMode::STOP)
      .network(NETWORK_INTERFACE_CELLULAR)
      .flag(SystemSleepFlag::WAIT_CLOUD)
      .duration(5min);
SystemSleepResult result = System.sleep(config);

We are getting reeadings of 980uA which seems much. Could this be right?

I’m not sure what’s causing the results you are seeing. With .network(NETWORK_INTERFACE_CELLULAR) the cellular modem is left on (like the old SLEEP_NETWORK_STANDBY) which is recommended for any sleep duration less than 10 minutes. However, you should be getting consumption around 23 mA, not 980 uA.

Without cellular network standby, you should be getting around 538 uA in STOP mode.

Another thread on the subject leads me to believe we should expect to see 123uA see Sleep current for B523

Sub 150uA would be great for our use-case but 1mA let alone 23mA would be show stoppers for us.

We have spent considerable time testing current consumption on P1, Xenon, Argons, Borons and now B523 som. It’s not easy for us to test this and some times we get results that aren’t fair because of misconfiguration or not being given clear instructions from the documentation. Please provide official numbers. This would save time and help us plan our product development.

Thanks for any light on the matter.

It depends on your sleep mode.

If you are using ULP mode in Device OS 2.0.0 with wake-by-time with cellular off, it should be around 56 uA.

Hibernate mode (SLEEP_MODE_DEEP) should be 30 uA, but you can’t wake by time in hibernate mode, as the RTC is turned off as well.

I’m using the following sleep, and getting to around 16mA. 2.0.0rc. Is there any way to bring this down? I need to connect every 3 min, so I need to stay standby.

config.mode(SystemSleepMode::STOP)
	.gpio(D2, RISING)
	.duration(180s)
	.network(NETWORK_INTERFACE_CELLULAR);
SystemSleepResult result = System.sleep(config);

16mA to 23mA is about as low as the B523 will go with .network(NETWORK_INTERFACE_CELLULAR). The Quectel EG91-E uses quite a bit of power when idle.