Signal strength/status question

Is there a way to get more detailed information on signal strength/connection status out over serial than I can with

SerialLogHandler logHandler (LOG_LEVEL_ALL);

I can’t get a Boron to connect to the internet, and it’s sitting in the same place on my desk that it had no problem with connected previously. I’ve tried flashing Tinker to it and it still won’t connect, so it’s probably not a problem in the software I’m running on it.

Is there some way I can view what it’s doing on the cell network?

I do know I’m not in a great location here - my cell phone reports an LTE signal strength of about -98 dBm, and I’m pretty sure its the same provider that particle is using (Telus)

You could try this

So, I have that running now, and I get:

0000015495 [app] INFO: Starting Tests!
0000015495 [app] INFO: Platform: Boron
0000015495 [app] INFO: Binary compiled for: 1.5.2
0000015496 [app] INFO: Cloud Debug Release 1.5.3
0000015496 [app] INFO: System version: 2.0.0-rc.4
0000015497 [app] INFO: Device ID: e00fce682b62321367e45b44
0000015497 [app] INFO: Power source: USB Host
0000015498 [app] INFO: Battery state: disconnected, SoC: -1.00
0000015498 [app] INFO: This device could have Ethernet (is 3rd generation)
0000015500 [app] INFO: FEATURE_ETHERNET_DETECTION not enabled, so Ethernet will not be used (even i
0000023508 [app] INFO: deviceID: e00fce682b62321367e45b44
0000023509 [app] INFO: PMIC inputVoltageLimit: 3880 mV
0000023510 [app] INFO: PMIC inputCurrentLimit: 500 mA
0000023511 [app] INFO: PMIC minimumSystemVoltage: 3500 mV
0000023512 [app] INFO: PMIC chargeCurrentValue: 896 mA
0000023513 [app] INFO: PMIC chargeVoltageValue: 4112 mV
0000023513 [app] INFO: modem is not yet responding
0000023522 [app] INFO: Still trying to connect to cellular 00:00
0000023524 [app] INFO: Power source: USB Host
0000023524 [app] INFO: Battery state: disconnected, SoC: -1.00
0000033513 [app] INFO: modem is not yet responding
0000033522 [app] INFO: Still trying to connect to cellular 00:10
0000033522 [app] INFO: Power source: USB Host
0000033522 [app] INFO: Battery state: disconnected, SoC: -1.00

and then it keeps going with “Still trying to connect to cellular”

I had a particle Boron that I hadn’t opened yet, so I tried setting that up and it works.

So what would the problem be here? Is it something on the carrier’s side where the boron is blocked from connecting? Did I break something on the Boron itself?

I don’t have specific experience with this, but this is in the documentation. If it had worked, now isn’t, I’d look into the possibility of what is described below:

You must not turn off and on cellular more than every 10 minutes (6 times per hour). Your SIM can be blocked by your mobile carrier for aggressive reconnection if you reconnect to cellular very frequently.

If you are manually managing the cellular connection in case of connection failures, you should wait at least 5 minutes before stopping the connection attempt. When retrying on failure, you should implement a back-off scheme waiting 5 minutes, 10 minutes, 15 minutes, 20 minutes, 30 minutes, then 60 minutes between retries. Repeated failures to connect can also result in your SIM being blocked.

Who do I ask about that? How would I find out if it was blocked?

I’m using Particle’s built-in SIM here.