[Resolved] Photon Dead After Low VIN


#29

It would be great if there would be a BIG WARNING on a datasheet that low voltage can FRY a photon board. I did definitely not expect this to happen, I would expect it not to work, but not to fry the whole board…


#30

Is the photon soldered in place or on a breadboard/header ?
The eagle part for smd soldering the photon have very large pads, so if too much solder gets deposited onto them the photon will shortcircuit beneth the board.


#31

I soldered headers to the board and to the Photon, so I can easily remove or replace it.


#32

I took option 3: Soldered a new board with a healthy buck converter, set it to 5V, soldered headers to the next Photon, tried tinkering when hooked on the USB power supply, and then tried the same on my board. It worked. Phew.

Still wondering, what happened to the first one.

I just noticed that my Photon restarted twice…


#33

I’ve never seen digital electronics that can be permanently damaged by lower-than-spec power voltage (assuming no high voltage short duration spikes or LDO dropout faults).


#34

@Orkus i’m not sure but there might be an issue with the buck converter not being able to deliver sufficient current to the Photon.


#35

@stevech I agree and this is actually not acceptable.


#36

@Mora If you are asking me, the photon is with the headers on a breadboard.
I measured the resistance between 3.3V and GND and it is 0, which to my eyes means a short and while probably my 2nd power suppy blew out when connecting it to 3.3 pin and GND.


#37

Ok, so not related to the solderpads, just wanted to put it out there, so noone else needs to make my mistake anew :smile:

near zero ohm is indeed short, there was some threads where people found the metal shield was bend and short circuited something under it, in a way that the shield could be used as a reset switch…


#38

Be aware that these very cheap LM2596 boards are a great source of counterfeit chips. The “work”, usually, but (as you found out) many haven’t passed quality assurance checks; worse, the fake chips seem to fail in a full “pass through full voltage” mode in over-current situations (such as driving into a dead short…)

I would NEVER connect one to the unregulated 3.3v/5v pins on a MCU board (Photon, Arduino or otherwise) - the danger of a failure wiping out the whole system is to great.

-John


#39

Hi All,

I know @BDub took a look at this back in July 15’ and didn’t find an issue, but if you do learn more about what happened leading up to what you saw, or if you have steps to reproduce the issue we’d love to be involved and learn / improve from any bugs or anything.

Thanks!
David


#40

I’m experiencing similar symptoms to the original poster (chip below usb port getting really hot). I’ve had the Photon working for a while using USB for power but recently decided to switch to powering via VIN, I was supplying 5v via a LM78L05 voltage regulator. I suspect I may have at one point connect the 5v to ground and ground to VIN :frowning:


#41

Good thing I’ve seen this thread. I have 3 “dead” devices - 2 Cores and 1 Photon and all 3 seems to be working when I connect 3.3V

Great news!

Well, almost. Photon voltage regulator (that large black thing near VIN pin) gets extremely hot. Cores doesn’t seem to have such problem, but i’m still worried about using them like that. Any advice?


#42

You can desolder the regulator - or even replace it to get it accept 5V again.


#43

What are voltage regulators used on Photon and on old Core(white one)?


#44

This should tell
https://github.com/spark/core/blob/master/Bill%20of%20Materials/core-bom-v1-131011.xlsx
BOM line 33:

221-36-301545	Voltage Regulator	3.3V, 0.5A LDO		SOT223	IC1	Microchip Technology	MCP1825S-3302E/DB

https://github.com/spark/core/blob/master/PDFs/core-schematic-v1.pdf


#45

I seem to have fried two photons by connecting them to an old iPod touch charger… When I connect them directly to a 3.3V source they start up but something, I guess the voltage regulator, gets very hot within a minute or so. Is it enough to remove the voltage regulator (RT8008-33GB) to solve this overheating when I use them on 3.3V or is there something else to do to insure save operation?


#46

I believe removing the regulator chip will suffice…:slight_smile:


#47

@Maarten_CH, I concur with @kennethlimcp that removing the regulator is all you need. You can also replace it!


#48

@kennethlimcp, @peekay123, thanks for your reply! I removed it and it’s running fine at 3.3V. The soldering pads got a bit damaged so I don’t think I will be able to put on a new one…
However, I received a Pololu 3.3V Step-Up/Step-Down Voltage Regulator S7V8F3 last week so I can continue again :smiley: