Receive UDP Broadcast packet [SOLVED]

I am trying to receive UDP broadcast packet. I have a PC broadcasting a UDP packet but I can’t seem to get the core to receive it. I have udp.begin(port) set to the port number that the PC is broadcasting to. Is CC3000 blocking broadcast packets?

I figured it out I think. The Spark only receives UDP broadcast that are in its own subnet. My core IP address is: It will only receive a broadcast with a destination address of: I was try to send it a broadcast with address:


Insightful @skeller thanks for sharing your problem/solution!

I changed the thread title to include “[SOLVED]”, seems to be a convention folks are using, hope that’s cool (please change it around if not :slight_smile: !)

Yep, thats if fine! If you changed it it didn’t seem to stay, when I checked it wasn’t there. I updated it. Is there a way to mark a particular post as the solution? Other forums I use it will turn the post with the solution green so its easier to find.

Good idea @skeller. Yea, I’d imagine there is a way to do this with Discourse ( the thing that powers this forum ). Added this to our backlog of things to look into/fix/changes-to-make.