Proper procedure to flash Electron core firmware to 0.5.0-rc1?


#1

I can’t seem to find the reference on how to do this. I know I had done this once before and put 0.4.8 on my Electron. Now I see there’s even a 0.5.0-rc1 and want some of that!. How do I go about this again? I promise I’ll bookmark it!

Also, is it just me that thinks there should be two different terms for flashing the core firmware (0.5.0) vs. flashing your sketches (firmware.bin)? Or, as usually the case, am I not quite getting the nuance here?


#2

#3

If you want to be a beta tester for our new device updater, you can try that.

A formal release, with docs and a guide is coming, but it’s meant to be easy to use, so you should just be able to download and run it. Supported on Windows and OSX presently.


#4

@mdma, that link seems broken.


#5

wah-wah! It’s a private repo…one sec I’ll see about making it public.


#6

For now, I’ve moved the binaries over to the firmware release - look for “particle_system_firmware” for OSX and Windows.

The device updater for the Electron is also a beta release, so feedback welcomed!


#7

Still requires a login.


#8

fixed!


#9

Is the Electron issue with:

Retained variable not retained on Electron after SLEEP_MODE_DEEP

addressed in this release? I can not seem to find it on the notes in Github.


#10

Yes, it was fixed in 0.4.9


#11

@mdma I just tried the Windows based updater but it does not work.

I try to run it and get this error. I’m running a windows 8 , 64 bit.

I also try to install via Node.js by using this line:

$ npm install -g particle-cli
$ particle cloud login

But I get the following error message.


#12

Why is 0.4.9 not available on the Build IDE?


#13

Because there was no 0.4.9 release for the Electron. It went from 0.4.8 to 0.5.0-rc.1
Any reason why you’d want to use a hypothetical 0.4.9 rather than 0.5.0?


#14

I’ve not seen that error before - it could be from the underlying system - kivy. (Although the node problems you’re having might indicate a problem with your machine?) The updater app isn’t build on node, but python.

Thanks for the report, I will try installing on that OS. In the meantime, I hope others will continue to try the installer.


#15

Because I was waiting for the fix to:

Retained variable not retained on Electron after SLEEP_MODE_DEEP

I am a bit confused because the Electron was released with 0.4.8 and the fix for the above issue would be fixed when the Electron could use build 0.4.9 as mentioned in other posts.


#16

Does the updater exe depend on python to run? Do I need python installed for the Windows exe to run properly? Sorry if that is a stupid question.


#17

And what makes you assume that that fix won’t be included in a more recent version?
0.5.0 comes after 0.4.9 (which was an internal version if I’m not mistaken), and should thus contain all improvements from earlier versions. If it’s in 0.4.9, you can safely expect it to be in 0.5.0 as well.


#18

No, it packages python with the installer - all dependences are included in the download.


#19

Thanks for the clarification. It threw up a few other error messages first but I couldnt get them to come up again after the first time I ran it.


#20

The same for me. Something about not being able to locate a file in my win32 folder “pnp_something_”. Didn’t show after the first time anymore.