Problem running / installing particle agent/


#1

Hi Guys, wonder if you can help, linux is not my native tounge…

pi@raspberrypi:~ $ bash <( curl -sL https://particle.io/install-pi )
Installing the Particle Agent

Downloading packages

######################################################################## 100.0%
######################################################################## 100.0%
######################################################################## 100.0%
######################################################################## 100.0%

Installing packages

Reading package lists... Done
Building dependency tree       
Reading state information... Done
libssl-dev is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libavresample-dev : Depends: libavutil-dev (= 6:11.9-1~deb8u1+rpi1) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
(Reading database ... 121211 files and directories currently installed.)
Preparing to unpack .../particle-agent_0.2.4-1_all.deb ...
Unpacking particle-agent (0.2.4-1) over (0.2.4-1) ...
Preparing to unpack .../ruby-unicode-display-width_1.1.1-1_all.deb ...
Unpacking ruby-unicode-display-width (1.1.1-1) over (1.1.1-1) ...
Preparing to unpack .../ruby-whirly_0.2.3-1_all.deb ...
Unpacking ruby-whirly (0.2.3-1) over (0.2.3-1) ...
Preparing to unpack .../ruby-particlerb_1.3.1-1_all.deb ...
Unpacking ruby-particlerb (1.3.1-1) over (1.3.1-1) ...
dpkg: dependency problems prevent configuration of particle-agent:
 particle-agent depends on bundler; however:
  Package bundler is not configured yet.
 particle-agent depends on ruby-highline (>= 1.6); however:
  Package ruby-highline is not configured yet.
 particle-agent depends on ruby-thor (>= 0.19); however:
  Package ruby-thor is not configured yet.

dpkg: error processing package particle-agent (--install):
 dependency problems - leaving unconfigured
Setting up ruby-unicode-display-width (1.1.1-1) ...
Setting up ruby-whirly (0.2.3-1) ...
dpkg: dependency problems prevent configuration of ruby-particlerb:
 ruby-particlerb depends on ruby-faraday (>= 0.9.0); however:
  Package ruby-faraday is not configured yet.
 ruby-particlerb depends on ruby-faraday-middleware (>= 0.9.0); however:
  Package ruby-faraday-middleware is not configured yet.

dpkg: error processing package ruby-particlerb (--install):
 dependency problems - leaving unconfigured
Processing triggers for systemd (215-17+deb8u7) ...
Errors were encountered while processing:
 particle-agent
 ruby-particlerb
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libass5 libavresample-dev libavutil-dev libdc1394-22 libdca0 libdvdnav4 libdvdread4
  libenca0 libfaad2 libfftw3-double3 libflite1 libgme0 libgtkglext1 libilmbase6 libkate1
  libmimic0 libmjpegutils-2.1-0 libmms0 libmodplug1 libmpeg2encpp-2.1-0 libmpg123-0
  libmplex2-2.1-0 libofa0 libopencv-core2.4 libopencv-flann2.4 libopencv-imgproc2.4
  libopencv-ml2.4 libopencv-video2.4 libopenexr6 libsbc1 libsoundtouch0 libspandsp2
  libspeexdsp1 libsrtp0 libvo-aacenc0 libvo-amrwbenc0 libwebrtc-audio-processing-0
  libwildmidi-config libwildmidi1 libzbar0 rtkit
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libavutil-dev
The following NEW packages will be installed:
  libavutil-dev
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
14 not fully installed or removed.
Need to get 0 B/183 kB of archives.
After this operation, 561 kB of additional disk space will be used.
(Reading database ... 121211 files and directories currently installed.)
Preparing to unpack .../libavutil-dev_6%3a11.9-1~deb8u1+rpi1_armhf.deb ...
Unpacking libavutil-dev (6:11.9-1~deb8u1+rpi1) ...
dpkg: error processing archive /var/cache/apt/archives/libavutil-dev_6%3a11.9-1~deb8u1+rpi1_armhf.deb (--unpack):
 trying to overwrite '/usr/include/libavutil/adler32.h', which is also in package ffmpeg 3.1.1-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libavutil-dev_6%3a11.9-1~deb8u1+rpi1_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Running sudo particle-agent setup

Let's connect your Raspberry Pi to the Particle Cloud!

You are already logged in as ewanrichardson@icloud.com.
Do you want to stay logged in as this user? |yes| yes
How do you want your device to be labeled in the Particle tools?
Name: |pi| pi
Generating RSA private key, 1024 bit long modulus
...++++++
....................................++++++
e is 65537 (0x10001)
writing RSA key
writing RSA key
Failed to restart particle-agent.service: Unit particle-agent.service failed to load: No such file or directory.
⠧  Claiming the device to your Particle account

#2

Which raspberry pi model are you using?


#3

its a 3 b v1.2


#4

Can you try running this command sudo apt-get -f install before doing bash <( curl -sL https://particle.io/install-pi ) again?


#5

you sir, are a god amongst men! that has worked.


#6

for some reason, the given bash command didn’t work on my Pi B, but after some tinkering, I found that re-organizing to a few commands did:

curl -sL https://particle.io/install-pi > particle-install-pi.sh
chmod u+x particle-install-pi.sh
sudo ./particle-install-pi.sh


#7

I have the same issue with RPI3B. I keep getting particle-agent service failed to load: no such file or directory


#8

Is anyone still using the raspberry particle system? I am new to this forum.
I keep getting:
Failed to restart particle-agent.service: Unit particle-agent.service failed to load: No such file or directory.
⠙ Claiming the device to your Particle account
Error claiming the device. Could not claim the device to your account

have tried reinstalling system updating etc