Powering Argon via 3.3v pin

I have a perplexing problem. I am trying to power an Argon exclusively via its 3.3v pin. Here are what I tried:

  1. I created a “blank” sketch and flashed it to an Argon using DeviceOS 5.3.1
  2. I connected the Argon’s EN pin to the Argon’s GND pin
  3. I connected a 3.3v bench supply set for max 1.5 Amps to the 3.3v pin of the Argon

The Argon’s status LED does the following:

  • On initial power up, it is briefly solid WHITE
  • It then flashes GREEN two or three times and the cycle begins again (likely resets)

I have tried this on two Argons with the same results. With a 1.5A setting on the PSU, the power available should be more than enough. I have also tried on two different perf boards, again with the same results. I also setting the PSU to 5v and powering the Argon via the VBUS pin and that worked fine.

I’m not sure if anyone else has had this problem.

The Argon isn’t intended to be powered by 3V3.

The output of the XC9258 3.3V regulator is connected to 3V3 and the CE pin of the XC9258 is connected to the EN pin.

I believe the issue is that regulator isn’t intended to be supplied with voltage on the output even when the CE is low. If VIN/VUSB isn’t powered, that will leave the chip unpowered, which may also cause issues.

I guess then the datasheet should not be saying this though :wink:

Hmm, maybe it is OK on the Argon then.

The Boron does have a warning that you cannot power it by 3V3.

Unlike the Photon, this pin CANNOT be used to power the Boron.

However, now that I think about it, even though both have a XC9258, the Boron uses a load switch connected to the Feather EN pin instead of the 3.3V regulator CE pin, and that might be the difference.

1 Like

I suspect that the note is incorrect and that applying power to the 3.3v pin (the Vout and Lx pins of the Torex XC9258) is not allowable. Looking at the voltage on the 3.3v pin, supplied by a bench PSU, I see this:


The XC9258 is clearly misbehaving and clipping the voltage low enough to cause a reset, especially when the radio is coming on. Perhaps the datasheet note should be updated to indicate that it is not possible to power via the 3.3v pin nor is it possible to bypass the XC9258.

The only alternative is to power with 3.6v on the Li+ pin, resulting in a horrible 1.6ma ULTRA_LOW_POWER sleep current. Bummer.

NOTE: The same problem occurs with the Photon2 which won’t even come on when trying to power from the 3.3v pin. In addition, the ULTRA_LOW_POWER sleep current is 35 mA when powered with 5v by VBUS!!!

I changed the text in the Argon and Photon 2 datasheets to match the Boron.


The Boron’s Modem requires the higher voltage which is why 3V3 can’t be used - there is no way other than via the Li+ pin to feed the modem.

I’m guessing that’s why it’s not recommended.
The Argon has only the NRF52840 to power.
*Correction: NRF+ESP32

And yet, it doesn’t work.

1 Like

What are you seeing? A continuously blinking Green Argon?

https://docs.particle.io/assets/images/argon/schematic-power.png shows a direct connection (except for an inductor) to both the VDD and V_WIFI from 3V3.

It’s working for me. Have you tried a different device?

@no1089, I tried with two Argons and I get a solid white to three green blinks cycle (it resets after the three blinks). I tried with both EN grounded and open with same results. And I use the same PSU as you. I will test with Argon out of the protoboard to be sure.

I just tested it and the results were… unpredictable. I’ll leave the datasheet as not supported.

With EN open, I reproduced peekay123’s behavior of green blink to reboot (white blink).

With EN grounded, it worked once. It also rebooted once.



Now that is unpredictable! It sounds like the XC9528 version or batch number may be at play. Definitely NOT supported as Rick said.