Argon no Wifi connection with external power source

Hi everyone,

When I power up the Argon with usb it connects right away to the internet and I can flash programs. But when I power it with an external breadboard power supply (3.3V) it just flashes the “seeking connection” LED and does not connect to the internet.

What am I doing wrong?

Thanks!
Chris

@Motley, how much current is your breadboard supply capable of providing? Also, did you follow these guidelines, especially the grounding of the EN pin?

3V3 PIN

This pin is the output of the on board 3.3V step-down switching regulator (Torex XC9258A). The regulator is rated at 1000mA max. When using this pin to power other devices or peripherals remember to budget in the current requirement of the Argon first. This pin can also be used to power the Argon in absence of the USB or LiPo power. When powering over this pin, please connect the ENABLE pin to GND so that the on board regulator is disabled.

Thanks peekay123!

Since posting I tried 5V to the VBUS and that seems to have solved the problem. But thanks, I had not connected the Enable pin to GND when I was working with 3.3V.

Very much appreciate your fast help!

Cheers

Chris

1 Like