Power gen3 devices with 7805 regulator

I have a circuit that successfully powers Photons, Xenons, and Argons with a 9V 1A power supply that is being regulated to 5V 1.5A with a 7805 linear voltage regulator. Both the input and output of the 7805 have 10uF capacitors following the Adafruit website's recommendation. The 7805 5V output is connected to the VUSB pin (and the GND is of course connected to GND).

The issue I have is this same circuit will not power an original Boron or Boron404X. I know I can directly power a Boron from higher voltages, but I want to use a common circuit to power any gen3 device.

When connected to the 7805 without a battery, the Borons will blink green rapidly as if establishing a connection, and after about 30s they will blink white, their amber battery LED will blink twice, and it will go back to blinking green.

When connected to the 7805 with a LiPo battery, the Borons will connect just fine, but their amber charging LEDs will blank rapidly. This indicates to me that they are running off of battery only and are unable to charge properly.

Reading the Boron docs, it seems like I should only need to provide 500mA through VUSB for it to work properly. What can I do to resolve my power issue?

I don't see any obvious reason this will not work. I set up a BRN402 with the setup you described:

  • 7805 linear regulator
  • 10uF caps on input and output
  • 7805 output connected to VUSB
  • 7805 input connected to a bench power supply, 9V with a 500 mA maximum current

I was able to successfully connect.

The behavior you are seeing is typical of insufficient power. I'd try a different 9V supply first. Possibly add a large (1000 uF) cap on the input and see if that makes a difference.

1 Like

Thank you for the quick response and suggestion @rickkas7. I originally tried a 9V 1A and a 12V 1.5A wall wart; both were switching power supplies and neither worked.

I was able to move the 10uF cap on the output to the input, doubling the input filtering, and now the Boron occasionally connects to the cloud (before dropping the signal after 1-2 minutes).

Your suggestion to increase the input cap is most likely the fix here. I will test this out with a larger cap when I'm back in the office next week and I'll post an update with the results.

Hi @dybm

The scenario you describe rings a bell....

I used a Battery Charger in a design a while back which had a 900mA power path current limit. As I am based in SA this can be a problem when trying to power GSM devices as e.g. the B524 (depending on signal quality), can require up to 2A pulse to connect.

The clever thing about the particular charge IC is that when it us unable to supply sufficient power from the external power source (or due to the limit on the power path) it closes an internal FET connecting the lipo battery directly to the system side power rail of the design and provide the power burst needed. Once this demand is not needed anymore, the system reverts back to normal operation and the battery charging continues.

This might also then be why you are able to start the device with the battery connected. Try to see if you disconnect from GSM after a while whether the charger LED returns back to normal.

As @rickkas7 said... it sounds almost certainly like a lack of power. Whatever the reason is though is to be determined.

Regards, Friedl.

It does sound like the 7805 regulator is folding back. Some of these 7805 regulators are only rated for 100mA, and will fold back when drawing more than that. Some even claim they are rated for more, but are fake. I would buy from a reputable source (if you got this from Adafruit I would assume it's good, but check it out anyway), and double check that you can load down the output of the 7805 with a 500mA load. Make sure the 7805 output does not drop below 5V while loaded as well. You might need to look the 7805 output with an oscilloscope to see it dropping and recovering. 7805 regulators can also fold back due to thermal regulation as well, so if it is getting too hot, that can also cause a problem. Just to make sure, you are using a TO-220 case style, hopefully with the exposed metal tab?


Thank you @BDub for the advice. I have several 7805s all purchased from Adafruit, and all units are producing the same result. They are indeed the TO-220 style and are using the recommended heat sink.

I ran a simple blink sketch on my Boron with cellular disabled, and monitored the voltage using a handheld signal generator. With cellular disabled I read a consistent 5V output:

Trying again with cellular enabled, I was reading inconsistently between 4.5-5V as the Boron blinked green trying to establish a connection:

The Adafruit 7805 is listed to output up to 1.5A at 5V. With the attached heat sink, I am recording <100°F after letting the device run for ~1 hour, so I don't believe it is being thermally throttled.

IR camera photo:

Same setup as above:

Today I was able to test out a larger input capacitor, stepping up to 100uF from 10uF. This change did not make any noticeable differences on the handheld chart or in the Boron's ability to connect.


Thanks for the tests and pictures. Try adding the 100uF capacitor closer to the VUSB input (so on the 7805 output). Right now it's really far away with long leads, so there's lots of inductance counteracting the bulk capacitance.

It's unclear to me if your portable scope/logger can trigger fast enough to show dips below 3.6V or so.

What 9V supply are you using?

When I power my Boron 404x with a lab supply, 5V@100mA applied to VUSB and GND, it resets constantly. It needs at least 120mA to be able to connect reliably.

Another simple thing you can try is to put TWO of your 7805's in parallel. If they are limiting to 100mA, doubling them up should show an improvement. This is not the best advice long term, but for a quick test it should tell us something.


I just wanted to mention that these linear regulators like 7805 can oscillate or ring under certain conditions with quick current demand. The recommended caps are something like 0.22uF at the input and 0.1uF at the output to help suppress high-frequency oscillations, in addition to any bulk electrolytics you have. As @BDub said, the inductance of the long wires you have on a breadboard is working against you here.

These problems can be hard to see on a scope with limited bandwidth such as the one shown.


Hi -


I am not convinced simply increasing the size of the input Cap will work, or that it is good practise. Unless of course you opt to use a SPC.

having said that and IMHO ... Seems like this is trying to make something work that just isn't, whilst there are ample LDO's out there that will not need any 'workarounds' to power a Boron. Just a thought :wink:

I use LDO's on every single project to supply up to 2A power for B524's to connect to 2G if need be. I am fairly sure you will find some for around $1 - $2 that will do the trick. You could e.g. use the ISL80102 for this purpose, depends on how comfortable you are with QFN packages. There are more simple packages depending on whether you want an adjustable output or not.

Hope you solve the problem :slight_smile:

@dybm -

Just curious, have you tested without thr Heatsink. Nice images indeed :star_struck:

You could swap to a Murata power OKI-78SR-5/1.5 switch mode drop in replacement for linear 7805.
Doesn't solve the root cause, but should work.:+1: Also more efficient too.

1 Like

I don't think we are trying to add workarounds to implement a long term fix. Only trying to understand why @dybm's 7805 doesn't seem to work well (unlike Rick's). It should work on the Boron LTE without extra bulk capacitors, but something seems to be preventing it from doing so. Perhaps it's the 9V supply current? It could be long wires, fake 7805's, or even high impedance connections inside the jumper wires. I've seen those overmolded jumpers fail so many times I stopped using them and only use the crimped premium ones now. The overmolded ones have a wire soldered to a pin, and the wire can easily break, and look like it's still making contact because the overmolding holds it in place.

1 Like

Hi @BDub -

I see...

Unfortunately I do not have a similar regulator on hand, would have been happy to test on my side. Having said that and as you mentioned, it could also be 'fake' component which make it even harder to pinpoint the exact cause.

I was hoping to see some temperature graphs on the datasheet but seems they do not provide the info. I doubt though that, if it is rated at 1.5A, it should be overheating unless the continuous current draw is quite close to that maximum?

Plausible yes. Could also be some other things as you mentioned, breadboard for one.

From the scope images supplied by @dybm the voltage does not seem to drop below ~4.5V. Normally 4.5V would not concern me, but the fact that it is dropping from ~5V to ~4.5V at all, indicates to me there might be an even bigger drop which the particular scope is not catching. Seems then indeed that the supply current is not adequate resulting in a significant voltage collapse :thinking:

Just my thoughts... hope it helps!!


1 Like

Thank you to the many kind people who offered their suggestions. To not bury the lede, I now have a working circuit board powering a Boron from my original 9V source through a 7805. I'll explain in detail below the testing that led me here for anyone Googling similar issues in the future.

Project Goals

  • Design a circuit board that can accommodate any particle gen3 or Adafruit Feather board.
  • Power the board with a single 9V power supply (required to power a pressure device with a 9V input).
  • Regulate the 9V input down to 5V for the microcontroller.

Original Thought Process

Adafruit offers one 9V wall supply: https://www.adafruit.com/product/63 and one 5V voltage regulator with sufficient current to power an Argon or Boron: https://www.adafruit.com/product/2164.

I read through the 7805 datasheet which recommends using a 0.33uF cap on the input and a 0.1uF cap on the output:

However, reading through the Adafruit description for the 7805, they recommend using 10uF caps on the input and output:

Not knowing much about capacitor sizing or voltage regulation, I designed a simple board in KiCad to connect a Feather footprint device with a 7805, barrel jack plug, on/off SPDT switch, and an input and output cap. I ordered the board and Adafruit components the same day.


The components arrived weeks before the circuit boards. I assembled all the components on a breadboard and discovered the issue I raised above. In an attempt to resolve my power issue, I tried the following:

  • Swapped out the breadboard for several other breadboards.
  • Increased the input power to 12v 1A from 9V 1A.
  • Moved from long jumper wires to shorter pre-cut length wires.
  • Increased the input filtering cap from 10uF to 100uF.
  • Reduced the input and output filtering caps from 10uF to the datasheet's recommended 0.33uF input and 0.1uF output.


The circuit boards arrived the other day. I assembled my components as closely to the datasheet spec as possible by using a 0.1uF cap on the input and a 0.1uF cap on the output. I'd have preferred to use 0.33uF on the input but I only sourced 0.1uF capacitors and my circuit board design only accommodated one input and one output cap.

With everything soldered together, the circuit works perfectly every time and runs continuously without any power interruptions. The only thing I can imagine is the breadboard + leads created problematic resistance that a soldered PCB overcame. I wish I had a more satisfying answer, but at least I'm glad I took a stab at final assembly before I had a working prototype.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.