Ping using particle cloud not working?


I use quite a lot the particle cloud calls to do all kind of stuff like claim a device, get an auth token, etc… no real issue until then until I tried to use the ping function.


curl<propoer device ID>/ping \
       -X PUT \
       -d access_token=<proper initial token or just created access_token>

This returns always the same:

{"error":"invalid_request","error_description":"The access token was not found"}

Even if I can use right before and right after the same token to retrieve other data (like list devices for instance). Anyone having the same experience with the ping?

Best regards,


(ScruffR: reformated the text blocks to make the <...> appear in text and not be interpreted as HTML tags)

I assume you put the device ID between the two // before ping.

However, was it exactly like that, in 3 lines? If you span across lines each line has to end with a backslash \ otherwise the 2nd and 3rd lines will be ignored and you’ll get that error. Or you could just combine them into one line.

1 Like


Yes I put the deviceid in between the // … I also tried the version in one line, I also tried with a software like Insomnia (i.e Postman) … always same result.
I tried it also with alamofire (because I develop on iOS), same result in the feedback Json.


Not sure what’s wrong then. I tried this command (not actually the device ID or token) and it works:

curl -X PUT -d access_token=72a2f53299959e01bc3956ab635dcb0cf9832454

Make sure you don’t have a space between the = and the first character of the access token.

There are two different errors, the one you mention where the access_token is not found in the request, and “The access token provided is invalid.” which means the token is invalid. So it’s most likely a subtle problem in how your request is formatted.

mm … writing the same command now with again a brand new token has produced the result I was expecting … sorry about the trouble and thanks for the quick help :slight_smile: