Photons that I cannot reset

Hi all,

I have 2 photons in pcbs that I have been reprogramming over the last week or so, quite a few times. Today what I am finding is I cannot get them to take a factory reset. I hold the mode button down through the magenta, yellow, green , white sequence and release during white as before. The photons blink green then blink cyan then breath cyan. They never go to blinking blue (listening mode) which is what I am expecting.

Any ideas?

Could you try updating to the latest release

Please do this even if you tried the beta release of 0.4.2 before - this has some additional changes, in particular it updates the bootloader which is responsible for factory reset.

1 Like

Thanks @mdma,

That worked like a charm on both units.

I am interested in how the fix worked. Did something get corrupted on my device and I just overwrote the code also going to a newer version in the process or was the device in an unintended state because of a flaw in the old code?

The area where settings were stored could become corrupted because the data wasn’t being erased correctly by the WICED library we depend upon. I fixed the erase procedure so that the settings storage now works as it should.

1 Like

Thanks @mdma It helps a lot with confidence in the fix when we know the why.

1 Like