Photon xCode DeviceSetup doesn't work


#1

Hello,

I had a new Photon – never connected to the internet before, and I’ve been following this guide for xCode. I’m creating my own app to use with this.

https://docs.particle.io/guide/how-to-build-a-product/mobile-app/

When Xcode compiles, there are maybe 30 warnings about various parts of the PODs library related to the setup and cloud api being deprecated since IOS 9.0. Most are related to UIAlertView having been deprecated – which I assume isn’t that big of a deal.

For my interests, I was attempting to complete the device setup example.

When I did it, the device did not complete setup. I found it on the wifi network (“Photon_XXXX”) and connected, but then when you switch back to the setup screen it just got stuck at that page. It looked like the connection with the device kept resetting over and over.

When I tried using the Particle app, it worked without a problem.

My guess is the libraries/code released no longer works with the latest IOS, but you guys have updated the Particle app to fix these issues. Anyone else experiencing problems with custom iOS apps and the Photon?


#2

No one has a similar issue? Anyone try recently to use the Spark Device Setup on a Photon as outlined in the documentation?


#3

This is now causing my app to crash. It seems that UIAlertView is no longer supported and the iOS SDK has not been updated to use UIAlertViewController instead…

This now mean you’ll have to do every step manually until the SDK is updated.