Photon won't connect to cloud


#21

You can download the 0.5.5 binaries here:

Just flash part1 and part2 by USB in --usb (DFU blinking yellow) mode. There is a bootloader downgrade from 0.7.0, however 0.5.5 will handle that automatically for you so you don’t need to do anything special.


#22

Nope - no luck on this either. I confirmed with $ particle identify that 0.5.5 is the system firmware version.

My last use of this device was a RESTful server where I set manually the IP, Gateway, DNS etc. So no way to manually add these at setup or do they require some cloud interaction just to get to the point of accepting coding?


#23

@mjohannessen, have you tried rebooted your router? Your MAC may be using cached IP data whereas the Photon needs the DHCP to provide a valid lease. Do you have any other Photons connected to the same router?


#24

Oh, if you’ve set a manual static IP that very well could be the problem. There’s basically nothing that clears the setting, you can flash user firmware, system firmware, clear Wi-Fi credentials, and the setting will still stick.

Flash this to switch back to dynamic (DHCP):

#include "Particle.h"

SYSTEM_THREAD(ENABLED);

void setup() {
	Serial.begin(9600);

    // To switch back to dynamic IP, use:
    WiFi.useDynamicIP();

    // Turn on the D7 LED so we know the operation completed
    pinMode(D7, OUTPUT);
    digitalWrite(D7, HIGH);
}

void loop() {
}

Since you currently have 0.5.5, you may want to do something like:

particle compile photon dhcp.cpp --target 0.5.5 --saveTo firmware.bin
particle flash --usb firmware.bin

#25

Thanks - that did the trick. Thanks for the compile example as well - very helpful. I suppose I can now go back to 0.7.0