Photon power shield fuel gauge SOC incorrect when charging on startup

I noticed inconsistent readings for the state-of-charge depending on whether the battery is charging on Photon startup or not.

To replicate:
-No charge on startup

  1. Disconnect charging cable
  2. Reset Photon
  3. Get soc reading, e.g. 30%

-Startup while charging

  1. Connect charging cable
  2. Reset Photon
  3. Get soc reading, e.g. 60% (-> much higher)

My guess is that the initial SOC estimate of the MAX17043 is heavily influenced by the charging. However that is very surprising and defeats the purpose IMO. The values are also not converging when running a while.

I also tried the SparkFun battery shield, which has the same IC, the problem is the same.

Has anybody experienced the same? I use a 2000mAH battery LiPo.

I’m glad someone else posted about this.
I’m also using a 2000 mAh battery, and confirm the same problem. As soon as I reset without usb, and published the values, I can see that SoC goes to 97% when initially running on usb it reported 161% even after disconnecting power.

Same issue here. I was using SparFun’s shield and it went from 30% to 60% when the USB was plugged in. I have no solution to offer.

@dep4gb Your above 100% readings probably mean you need to call the reset calls on the battery and wait a bit. I had readings in the 200% range, then did lipo.begin() and lipo.quickStart(), followed by a 500ms delay (was necessary) and it worked. I had this issue because I was putting the Photon to sleep. Maybe you too?