Photon in RED SOS hard fault mode, unable to put into safe mode


#21

I have two photons that have this behavior - we believe the cause to be ESD, since replacing the firmware by reflashing the entire chip via JTAG doesn’t help.


#22

Ok, so your saying the photon has let the magic smoke out?


#23

Yes, that’s our current best guess - it’s not conclusive yet, so keep hold of them, but you probably should look for replacements since there is no known way to recover these devices at present.


#24

My photon was running a temp logger overnight and the next morning was blinking SOS then one longer red flash. Has same symptoms as most of the above. Puff!


#25

Did anyone ever find a resolution to this? I have exactly the same problem.

Setup a new Photon, worked my way through the tutorial, and then had to leave it alone for a while. Came back to it today and I can’t get any life out of it at all - all it does is flash the SOS hard fault light twice, and then reboots. It won’t reset into safe mode - releasing setup while the light is flashing magenta just goes directly back to hard fault mode. It will go into DFU, and the firmware will install, but it just goes right back to SOS.

It can’t be a short etc because it hasn’t been used for anything other than the tutorial yet. Any ideas what could be going on?

Thanks!


#26

@FlyboyUtah & @barrythelion, if it’s the same issue you might need to open a support ticket.
Add a link to this thread in the ticket.


#27

Have you been able to get to the bottom of this issue?


#28

They just sent me a new one - not sure if that’s considered a fix :slight_smile:


#29

OK, now I’ve got the same problem. Photon was running happily 24/7 and hadn’t been rebooted since last November. Two days ago it started blinking SOS, one second pause, one red flash (I guess you’d call it a “T”). Also, the D7 blue LED is stuck on.

I am unable to enter Safe Mode. I can get it to blink magenta but when I release the Setup button, it goes right back to SOS-T.

If I keep holding down the Setup button, it eventually goes to fast flashing yellow (DFU mode?). At that point I get the “USB connected” da-ding sound from the PC it’s connected to. The blue D7 LED remains on.

I tried a f/w update and it claims to have worked:

Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\User>particle update

Your device is ready for a system update.
This process should take about 30 seconds. Here goes!

! System firmware update successfully completed!

Your device should now restart automatically.
You may need to re-flash your application to the device.

C:\Documents and Settings\User>Microsoft Windows XP

But then it went right back to SOS-T. I cycled the power - no difference. I tried Safe Mode again and got the same behavior as before. I tried redoing the f/w update - same results. I tried the Particle app - claims no devices found. Any ideas? Any chance the Blue Norwegian maneuver would help? I have one Photon left that could power that trick.


#30

After the system firmware update you should also run particle flash --usb tinker
BTW, what version CLI have you got?
Is it most recent (currently 1.20.1)?


#31

It was 1.16.0 so I upgraded it to 1.20.1 and tried the particle update again. Didn’t help. Nor did particle flash --usb tinker. It just keeps flashing SOS-T.

I opened a support ticket. They had no better suggestions so they’re going to send me a new one.

I haven’t had much luck with my weather station. I cooked off the first Photon by accidentally touching Vin to the output of the solar panel. The second one died the mysterious Death of the Dim D7 after the battery ran down one time. Now this.


#32

Hey everyone. I connected my photon (that was failing) last week and updated it via CLI and it suddenly came back to life. So something has been fixed in the firmware…


#33

Have a Photon that has been working great for many months and today it’s giving me the SOS 1 Hard Fault Error.

I put it into DFU mode, updated successfully, then loaded Tinker Successfully, but still get the Hard Fault Error message.

The Photon will not go into safe mode either.

No idea what caused this :scream:


#34

@RWB did you managed to fix it?


#35

NO, Threw it to the side and grabbed another.

Any suggestions?


#36

Do a particle update and particle keys server followed by particle keys doctor DEVICE_ID