Photon flashing cyan with red bursts [SOLVED]

Indeed. I probably should have done that before spending an hour getting completely frustrated trying to figure it all out myself. I have nothing but praise for the Particle community and have always gotten help right away with my multitude of Photon problems.

That said, in my first post, after it says

a little further down it also says

leading to further confusion. If I might make a suggestion, a more helpful message might be to say "Please run "particle login" from a command prompt" instead of just "Please login". Or even better yet, if the program knows a login is needed at that point, why not just offer up the login prompt right there, like "Please enter your email address". I'm not saying there's anything wrong with the way it works now, just that from the perspective of someone who is not a Photon expert, I found it confusing.

So anyway, I went back and ran particle login and got "Successfully completed login!". Then following rikkas7's advice, I did a particle identify which did indeed return the device id and f/w v. 0.5.2.

Next, I followed BDub's link

But when I ran the setup program it opened the installer dialog and then popped up an error "Your internet connection seems to be not permitted or dropped out! Please reconnect and click Retry to resume installation."

Well there's nothing wrong with my Internet connection. I even tried this on a different PC and got the same error. So I'm not going to get aggravated, I'm just going to ask for more help. How do I get this installed?

Just out of curiosity, does this try to talk to a server in China? Because I have all of .cn blocked at my router, as well as a number of other malware-type Internet domains.

Oh, and is there a way to patch up the title of this thread? I missed the n in Photon.