Photon Endlessly Blinking Cyan

Never connects to the cloud even though my wifi is up and running… any ideas?

This?
https://docs.particle.io/support/troubleshooting/common-issues/photon/#blinking-cyan

Have you updated your device?
Has it ever worked?
What Wifi are you on, channels, frequency, etc?
Any other Photons connecting successfully?
Any other colors than cyan visible during blinking (most notably orange)?

Seriously? Right out of the box I need to install a half dozen other programs and download a dozen other files… When I have a free afternoon, or maybe I’ll just get a new one.

You asked for an idea, I gave you one :wink: There was little information to go on, and that’s one of the more common causes. The other questions I’ve asked are to help determine if there might be something else going on so you don’t have to install “a half dozen other programs and download a dozen other files…”

No worries… I just have a very specific (and relatively easy) idea for this device. I’m going to hack my condo’s intercom/buzzer system to work with a Blynk app of my creation. I already have the relay module. Anyway, I’ll tinker around with this one after I finish that project. Incidentally, I originally thought Intel Edison for this project but that’s kind of overkill… Here’s what happened to the current photon: all was well (breathing blue) until I connected the first time to Build. No issues with Blynk even. Then, rapid cyan… that’s all I did. I looked at the various ROMs to see if there was a new one (there wasn’t) then blinkblinkblink…

another thing to consider trying. hold down the setup button for 10 seconds. then use the particle setup app for your phone to re-enter the wifi credentials. i had to do this for one of mine and that solved it. hope it helps

What do I need to consider ‘connect to build’ to be? The first time it had a cloud connection, or the first time you flashed something using Build?

So you managed to flash Blynk to it, after which it became erratic?

Not sure what you’re referring to with the ROM thing, is it the system firmware, or the Blynk library?

Before trying the suggestion mentioned above, could you try Safe Mode and see if you can flash Tinker or ‘blink an LED’ to it?

That’s the first thing I tried, to no avail… it’ll go into listening mode but it ultimately fails to connect with the following error: Setup process couldn’t disconnect from the Particle device wIfi network. This is an internal problem with the device… try running setup again after resetting if needed.

It began it’s cyan blinking after I added the device to Build and looked for the latest firmware. I never flashed anything through Build. Blynk flashed perfectly fine!

You never flashed anything, yet you flashed something? Care to elaborate?

Can I safely assume at some point the device worked properly? That is, breathing cyan, showing up as online, and capable of being flashed?
Can you take me through the steps of what it’s been through, configuration, flashing, failing?
Does the blinking cyan happen immediately now, and does it show other colors as well?

I dare to contradict!
@Moors7 is one of the most helpul members of this community and hence was granted the Elite status years ago.
But maybe there is a misunderstanding or wrong application of terms.

When you say “Blynk” do you actually mean “Tinker” (which is the out the box application firmware on the device)?
If so, I’d guess that “wrong” term had pushed @Moors7 on a wrong path which does just not fit your other info.

And if you actually meant “Blynk”, why not just tell us how you got that on in the first place?

1 Like

@InfoSysLib, there is no need to get rude. @Moors7 is extremely competent and simply tyring to help. I believe the confusion stems from the lack of key information, mainly the fact that you seem to suggest you put Blynk on your Photon but not HOW you put it on your Photon:

Then later:

I hope you understand the confusion. So the first time you connected to Build (assuming web IDE), you flashed the Blynk app from the libraries available on Build? I use Blynk quite often so I can help once I understand what steps you’ve done so far.

Blinking cyan means the Photon is trying to connect to the Particle Cloud. So it sounds like the wifi part is ok but not the cloud. It may be the claiming part of setup did not complete so it won’t be able to connect to the cloud. There are steps you can follow using a serial terminal app on your PC that will allow you to get the Photon’s ID so you can manually claim it on Build if you are interested.

2 Likes

Hey @InfoSysLib – Will from the Particle team here. I’m sorry you’ve been having issues with the Photon. From my perspective no one is trying to troll or intentionally aggravate you, but rather clarify the confusion over how your device got into its current state so that we can be most helpful.

If you’d like to receive “official” Particle support, I’d recommend submitting a technical support ticket through our Support Portal. From there, one of our Tech Support agents can help you troubleshoot the device if you’re still having issues.

If there was a problem you encountered in the setup or flashing process, we’d love to hear your feedback and discover the root cause so that we can improve the user experience for others as well.

2 Likes