Photon, boost converter & AA batteries

Hello,

I’ve been working on this project that requires the photon to be powered form 1 or 2 cells AA batteries, i am using a 3.3 boost converter to maintain the batteries voltage to 3.3v, photon is configured to be in deep sleep mood and wakes up from a signal on (WKP) pin, so the overall current consumption is around 260uA (Photon + Stepup converter).

everything works great as long as i am waking up the photon daily it’s been running for ~4-5 weeks, but if i don’t wakeup the photon for around 4~5 days something weird happens when i send a signal to the WKP button the photon would flash White the SOS red for hard fault i guess, it never works again until i remove the batteries for (2~3 sec) then put them again it will run totally fine on the same batteries.

At first i thought it’s the batteries are drained but they give 1.5v on voltmeter so they are good batteries.

Does anyone have an idea on what’s going on after keeping it sleep for 5 days, is it something related to the batteries? stepups ?(btw i’ve tried different stepups with same results) or is it the photon itself ?

Thank You.

That’s not really a reliable test.
Without a load drawing some proper current (which a V meter doesn’t) you will mostly read 1.5V even on rather flat batteries (off-load or open circuit voltage).

@waleedq, what is the source of the “signal” on the WKP pin? Do you wake the Photon daily using WKP or via the timed wake?

Which SYSTEM_MODE and SYSTEM_THREAD modes are you using? Which SOS code are you getting?

The DHCP lease on the router may expire during the 4~5 day period. This will increase the time required for the Photon to renegotiate its link and may require more “burst” current than the batteries/booster can supply.

Yes you are right, on load the battery gives 1.3v, but the thing is i am testing with 2xAA and another photon using one cell the two are giving the same result after 4~5 days, taking in consideration that 260uA should be nothing considerable as based on the calculations:

260uA * 3.3.v = 858uW, a single AA cell would be rated at 2000-3000mAh so that would give us a minimum power of 2000 * 1.5 = 3000mWh so 3000mWh divided by 0.858mW = 3496 hour = ~ 145 days.

This is why i am just curious why it would die after 4~5 days.

Hello @peekay123,

The signal we are using is 3v from an external button, Yes i wake it up daily using the WKP not using a timed wake.

SYSTEM_MODE is manual, and the SYSTEM_THREAD is enabled, the SOS code we are getting is one red blink between 2 SOS patterns.

For the DHCP lease, this can be a valid point looking at my boost converter’s data sheet and the peak current (400mA) that the photon would use it seems that the boost converter can’t give enough current when we are using 1 battery cell, but the boost converter can give up to 600mA on a 2.4v which a 2 AA batteries can supply easily, so it should be working on our 2nd setup, as we are doing the test in parallel on 2 photons one with 1 cell and the other with 2 cells, both are having the same issue. when i remove the batteries and put them again everything starts working normally.

Have you tried running the Photon from a reliable power supply instead of the batteries and let it set for 4-5 days to see if the problem is in the batteries or in code?

That is the first thing I would try.

2 Likes

@bko didn’t think about that really, will test it on the power supply, let’s hope it’s a code issue.

Thank you!