Particle Workbench local compile error - Command not found


I just installed Particle Workbench on a clean install of Ubuntu 18.04LTS. I imported my project and installed the toolchain for 1.4. But when I try a local compile, I get a make error that ~/.particle/toolchains/gcc-arm/5.3.1/bin/arm-none-eabi-gcc: Command not found. Checking that folder, everything appears ok… ??? Any idea what I’m missing?

I’ve tried ResetEnvironment along with uninstalling and re-installing the local toolchains (multiple times). But still get the same error…


SOLUTION was as Nathan suggested - 32bit libs needed to be installed.

1 Like

Have you tried installing the 32-bit libraries?

1 Like

Thanks! I had just done that as you replied :slight_smile: That was definitely it, I hadn’t tried to run the compiler myself to see it wasn’t working. All working now!


i’m hoping to make this clearer in Workbench itself so at the least you aren’t left scratching your head about what this error means but for now we’ve documented the handful of additional hoops you need to jump through over on linux: