Particle to Webhook to PHP to MariaDB MySQL

This is the code to send from the Particle to the Webhook:
// This is the string to be published.
String data = String(PM25);
// This is the column that the string is published in.
Particle.publish(“Atmovision01a-to-PHP”, data);

The webhook is built like this:

The PHP looks like this:

I can not get my PHP script to display correctly in text and I can only post 2 images. My PHP script is in the reply below.

When I hit the “TEST” button while viewing my Webhook Integration, this happens in my database:

Unfortunately, nothing else posts in my database from the particle when it’s running… I plan to do SSL/etc. after I get this working. Does anyone know how to fix this?


What do you see in when you send the event?
You should also use PRIVATE for your publish call.

But the most important is that you have a case issue.
Once you are using a capital V while the published event uses a lower case v

1 Like

I don’t want to talk about how many things or how long I tried to troubleshoot without noticing the case issue. Thank you so much, everything works now!

1 Like