Particle serial wifi getting stuck


#3

I have the same problem. The suggested solution doesn’t work either, cos if I say no when it asks to scan the network. It gets stuck there.


#4

I am also having the same problem. What is the SSID name you’re trying to connect to? I would think that spaces or maybe dashes might be an issue. Troubleshooting here…


#5

I tried both those methods. Didn’t work. I’m not sure how to fix it. I ended up resetting the device and starting over by setting up a new device.

Keeps getting stuck when I hit “n” for scan nearby wifi?

or If I say “y”. I can see the networks and select one. But after I select one. it just hangs there.


#6

Same problem here…


#7

Can confirm, I’m also seeing the same issue.


#8

Which version are you guys using?


#9

Which version of what specifically? Node? The Particle package?


#10

CLI version


#11

I’m on particle-cli@1.8.22.


#12

That’s strange. Let’s first try to get you up and running, and then figure out what’s wrong? You can configure your credentials using a serial program like Putty of coolterm. There are some docs about that over here. Alternatively, you could try this website from a wifi-enabled device.
Are you sure you’ve installed the proper drivers for the device?


#13

I am also experiencing the same issue in Windows 10 Home version 1511.


#14

I actually got it to work once I put my photon in listening mode. If it wasnt in listening mode then the commands would get stuck. To put it in listening mode, just simply hold the setup button until it starts flashing blue.


#15

For particle serial wifi you’d indeed have to be in listening mode. As the name might suggest, it uses the Serial connection, which is what Listening mode will open.
That said, I’ve seen the above mentioned issues as well, while being in listening mode. In my experience there’s user code interfering, which can be circumvented if you go into Safe Mode prior to going into Listening mode. That’ll ensure no user firmware can mess with the progress and allow the device to connect in ‘peace’. That often worked just fine for me :smile:


#16

same problem, why wasn’t this addressed yet?


#17

It was, by updating CLI and suggesting a way to deal with it, since there are more factors on the users side than on the device side.

What version node, npm, CLI are you running on what OS?


#18

OS X el cap
Node 6

Latest version of cli

It worked after like a dozen attempts but photon still doesn’t connect to wifi


#19

And you have ticked off all the other usual causes:

  • no 5GHz WiFi
  • no channel > 11
  • WEP network need special passkey treatment
  • no Enterprise network
  • no captive portal
  • not selected a non-present external antenna
  • not set for static IP
  • solid clean power supply
  • no hidden SSID
  • your device is in Listening Mode

Have you tried via coolterm?


#20

I freshly downloaded the photonsetup.html
Power-cycle the photon. Put it in setup mode.
Then ran the
particle serial wi-fi
and entered SSID, securityType and WiFi password manually.
And that made it go through without getting stuck.


#21

We are having the same issue with spaces on SSID. Not able to connect with API 0.6.4.

Does someone know if new releases have solved this issue?

Thanks for your comments


#22

No double (tripple, quadruple, …) posting!