Particle P1 breathes white... AGAIN!


#21

Since we know the way to turn back P1 or PHOTON in healthy state, let’s give a try in CLI based DFU utilities Particle Update and Particle Doctor to check if any bug still exists.


#22

Well, the Particle Update from the CLI works just fine. Something is going wrong with Particle Doctor, i tried it and got the same error described above. The P1 after this, is turned to Breathing White which means that the WiFi chip is turned off. After that, neither Particle Update works.
This time, instead using buttons to turn P1 in Safe Mode (breathing magenta) and after that a flash of Tinker using the WEB IDE, i tried to flash it using the CLI–> “particle flash --usb tinker”. Success. P1 turned again in healthy state. Here is the message of CLI and i hope that will be helpful as in the two last lines something about invalid and valid is refered:


C:\Users\FOTIOS>particle flash --usb tinker
Found DFU device 2b04:d008
spawning dfu-util -d 2b04:d008 -a 0 -i 0 -s 0x080A0000:leave -D C:\Users\FOTIOS\AppData\Local\particle\node_modules\particle-cli\binaries\p1_tinker.bin
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Opening DFU capable USB device...
ID 2b04:d008
Run-time device DFU version 011a
Claiming USB DFU Interface...
Setting Alternate Setting #0 ...
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "Internal Flash   "
Downloading to address = 0x080a0000, size = 4740
Download        [=========================] 100%         4740 bytes
Download done.
File downloaded successfully
Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!

Flash success!

C:\Users\FOTIOS>

#23

That DFU message is a known, and harmless warning.[quote=“fotis, post:17, topic:37853”]
Error creating keys… Error: Command failed: C:\Windows\system32\cmd.exe /s /c “openssl genrsa -out 490033001751353431383737_rsa_new.pem 1024”
‘openssl’ ??? ??? ?? ??? ? ??? ???,
??? ??? ? ??? ??? ???.

Make sure your device is in DFU mode (blinking yellow), and that your computer is online.
Error - Error: Command failed: C:\Windows\system32\cmd.exe /s /c “openssl genrsa -out 490033001751353431383737_rsa_new.pem 1024”
‘openssl’ ??? ??? ?? ??? ? ??? ???,
??? ??? ? ??? ??? ???.

The Doctor didn’t complete sucesfully. Command failed: C:\Windows\system32\cmd.exe /s /c “openssl genrsa -out 490033001751353431383737_rsa_new.pem 1024”
‘openssl’ ??? ??? ?? ??? ? ??? ???,
??? ??? ? ??? ??? ???.
[/quote]

This is the part that’s problematic. OpenSSL is, apparently, still not in the system PATH. Give the tutorials I’ve linked you to a shot, and try adding it to the PATH.