Particle Functions not working with Electron

Hi There

I have deployed my Electrons remotely - they have been running fine with a publish event and then my server sending an ack back via a particle function call within 30secs so that the device can clear its buffers with the data that has been successfully received. the device then sleeps for an hour and repeats the process.

Today I started getting the same publish message continously every hour and with its retries which means that the ACK function is never being received.

I tried to send my ack function back manually using the particle CLI

On one of the devices I receved the following return value

particle call calm-vampire data_ack "OK"
Function call failed Exception during function call -------------THIS IS CONCERNING what is it.

on the other device

particle call elegant-captain data_ack "OK"
Function call failed Timed out. This is probably because it is actually offline

It has been working well for a week or more so just wondering if anything else could be wrong. This is in trials for us at the moment but it’s a 4hour drive each way to get to it, so I would really like it reappear before I begin losing data.


@marshall do you see the functions listed in

1 Like

Hi Kenneth

no the functions are not listed for this device.

Funnily enough it recovered listed its,functions and worked well again for about two weeks, and now the unit has again lost the functions being published, so my system level ack is not being received at the electron. My internal logs can only hold about 48hrs worth of data before it starts dumping it. I’m at 36hrs worth of outage time at the moment.

The web cosole shows the following “Last Handshake: Aug 8th 2017, 1:45 pm” this corresponds exactly as to when a publish event failed. and since then no functions have been successful.

I can see the publish events from the device coming through regularly on the hour so I know that it is still online, unfortuntaly it needs the ack to be returned before it will publish any new data.

Any thoughts on how to get it list its functions is appreciated.


@rickkas7 is there some logs we can see for the handshake?

I’m not sure I understand, Where to do I find such handshake logs?

Are these logs from the particle cli, the device itself (which in the field), or from my Node-RED application?

I’m happy to get/provide whatever logs you require.


Mark the ping tag (@…) at the start of the sentence :wink:
That request is directed at rickkas7

Thanks ScruffR, I didn’t relise the protocol for “pinging” someone. The functions never came back, The events are still being fired, but it’s not registering the functions any longer.

It’s online for at least 45secs as it awaits the application ack, before going back to sleep for another hour. Is this long enough for the Particle Background services to be fed, (i.e. Time Sync, and registering the functions etc).

Also when it is humming, it only stays online long enough to get the ACK back, then it waits a shorter period before disconnecting and sleeping again.

Thanks for taking an interest in this, its really sad to see it crumble like this at the last hurdle.