Particle Dev select device error atom out of date

Hello,

When I try to select device ( mesh ) in Particle Dev Mac, I get error atom is out of date: 1.19.0 installed, 1.33.0 latest.

I tried to uninstall and re-install again from Particle Dev Mac, same error come out.

when I see in the update section, everything is up to date.
How to solve this problem?

You can not used Dev to program MESH devices unfortunately.

Dev is being discontinued and is being replaced by Visual Studio Code + the Particle plugin for that software which does support programming Mesh devices. This VSC plugin is in beta right now.

I saw this same ATOM Dev error as you did tonight and also tried to update Atom and reinstalled Particle Dev to get things working again with the Photon and P1 boards.

I installed VSC but didn’t try to figure out how to use it because I really didn’t want to waste to much time on it if there are bugs preventing it from running smoothly but it did look promising and very similar to Particle Dev as far as looks.

I prefer Dev because I know it works but I know I’ll need to switch to VSC in the near future, just waiting for the bugs to get worked out as much as possible before making the switch since the MESH devices are on the shelf until newer firmware for them is released.

Yeah, I installed the atom dev after particle dev show error, same error come out.
after uninstall and install again all particle package in atom dev, not solve the problem.
See their repo (atom), they haven’t fixed it too.
I’ll looking about vcs now.
The particle dev can still be tried other than mesh.
So, what do you suggest to try mesh now? only web dev?

I’d definetly suggest Particle Workbench (aka VisualStudio Code + Particle extensions).
That allows pure offline building (which Desktop IDE - aka Particle Dev - never did), proper IntellisSense, code snooping (viewing function implementation and variable definition without leaving your current position in code), inline debugging (yet to come), code snippets and many more.
Although Workbench is currently alpha state, my results are quite satisfying. If I was you I’d still give it a spin - additionally the more people we have testing the quicker potential bugs can be found. Holding of trying just for the “obscure” feeling it might not be up to the task yet may cost you the chance to be convinced otherwise :wink:

However, you still can use Dev to edit your projects and then use CLI to build for mesh devices. This can even be done from Dev’s own terminal pane.

1 Like