Particle Desktop IDE compilation and flashing problem

Hello, every time I want to compile and flash a code to my photon, I need to close and reopen the Particle Desktop IDE each time, after each compilation or flashing…
I tried to reinstall the IDE but it didn’t help.


@yairsh, can you provide more details on any errors you get? What happens exactly that makes you need to close and re-open the IDE?

After I edit the code, when I press the “compile in cloud and show errors if any” or the “compile in cloud and upload code using cloud” it only works once. when I press again nothing happens and I get no error.
also, when I press the “compile in cloud and upload code using cloud” without compiling before, It only compiles and not uploading.
The only way to make the code compile or upload again is to close the ide and then re-open (only for compiling/uploading once… )


Ping @rickkas7

What operating system are you using? And can you take a screenshot of the entire Particle Dev window? If you don’t want to post that here you can submit a support ticket.

You need to create the ticket, and you’ll get a confirmation email, then reply to that with the actual screenshot since you can’t attach the screenshot to the web form.

I am using windows 10. I tried to reinstall the ide with no luck.

I believe the problem is that you have opened too high of a directory. Particle Dev does not build the tab you have open. It tries to build a binary with every file in the file tree to the right of the icons. This causes unpredictable behavior.

There’s a longer explanation of this problem and more tips here:

1 Like

I tried again with another project folder, and the problem persists.

Hi @yairsh
I think you forgot to select the device in which you want to flash the code. In both of your screenshots you can see “No devices selected”, so it’s better try to select the device before compiling and flashing. I hope this works.:smile:

1 Like

Hi @imran445
I already tested it with and without selecting the device. not worked :frowning_face:

In the screenshot above, the code tab is not saved, there’s blue dot to the right of the filename of the tab.

Make sure you save because if the file is unchanged on disk it won’t be compiled again. If Command-S doesn’t make the blue dot got away, try selecting Save All from the File menu.



I have the same problem. I opened ParticleDev, opened the project (folder), compile ONCE (which works) and then it no longer works, I cannot longer compile, upload, select device… nothing related to Particle. (I cannot even log out).

I clicked in all the icons/menu options and nothing happens. I have to close and reopen the IDE and now I can compile or upload ONCE. (No errors shows)

I have Windows 10 Pro x64 with Particle x64 version 1.19.

I would love to send the logs files, but I have no idea where to find them.

FYI The project is 4 levels in and the path is less than 40 characters, I already tried uninstalling and reinstalling the app.


Thank you!