Orenda Coffee Machine Flashing Cyan

Hello Particle Community

I have purchased a http://orendacoffee.com/ there has been many issues with this machine as people have described in a customer community on facebook.

I have contact Orenda support many times with my issue they have told me to keep doing the setup method. I have honestly tried setting up the device 40 times with 3 different mobile devices. I have also tried two different wireless connections but I keep getting the same issue. Device does not connect to the cloud, I have tried everything I can so I was hoping I might be able to get some help from this community

Device uses a Photon P1 I believe

Here is link to two videos of the status LED https://imgur.com/a/QAJS5dP

1 Like

Although the videos done’t show the whole process in one this does look a bit like a keys issue.

Do these modules expose USB connection?

1 Like

I did open up the spot where the hardware is. I could see the Photon device. I could not see any USB connection unless it is underneath the custom orenda chip. I didn’t bother to unscrew the chip as there’s a lot going on in there. is there any method to renew the keys without USB connection? Obviously the Devs of the system had to have access to this

Here is a pic of the hardware

In that case I fear you must rely on support to help you out. Maybe if you mention that you suspect a keys issue they might have some other suggestions than just their standard setup procedure.

Since you are not the “owner” of the device in regards to Particle’s terminology I’m not sure a support ticket at support.particle.io will help a lot, but maybe Particle can approach the creator in your behalf to find a solution together.

@rickkas7, what do you think is the best way forward with above issue?

This sounds like a really awful rollout experience for everyone. There are a few tips here, like making it forget wifi credentials etc:

One guy got so pissed off, he wrote his own firmware!

3 Likes

Yep I am well aware of that doc and Git Repo. Ive looked at the git but I dont think i need to go that far to solve my problem.

I am going to contact Orenda again with Photon Key information see what they come back with. If all else fails i will be requesting a refund from them because the product delivered does not work as it was advertised.

If only there was a USB interface i could have probably solved this issue myself.

Thanks for all the help

1 Like

I have sent this message to the Orenda customer support. I will await their response. It is extremely frustrating when you buy a $400 dollar coffee machine and it is not working as advertised. It would be nice if someone at Particle could reach out to them as I am sure they have purchased a massive order of Photon’s. I am not the only one with this issue and this company will probably go belly up if they are unable to implement their tech properly.

When I suspected the keys issue, that wasn’t in seeing the cyan flashing but rather the red/orange flash in between the cyan flashes. The cyan flashing only indicates the attempt to connect to the Particle cloud, but when a series of red/orange flashes is mixed in, there are other reasons preventing that. Most common is the issue with keys.

See here
https://docs.particle.io/support/troubleshooting/common-issues/photon/#public-key-reset
and here
https://docs.particle.io/reference/led/photon/#red-blink-basic-errors

2 Likes

We (or at least I) became aware of the Orenda situation several months ago, via a support ticket filed by Mr. Nualls. He was trying to reverse engineer the design so that he could write his own firmware, to make the machine actually usable. Someone at Particle (I don’t remember who) did reach out to Auroma, with no response.

Just last week I had another person write in, trying to get some help. In his case, the Orenda mobile app suddenly told him that the Particle device had been claimed by someone else. In our system, the device is still showing him as being the owner, so it seems that that problem could only be soved by Auroma, and from what I’ve read in the above-mentioned Facebook group, the company is unresponsive to requests for support.

I am really liking my Nespresso machine at the moment… It Just Works.

cheers,
ParticleD

1 Like

@ScruffR Currently the device is flashing Cyan same as described in the Docs. From what i have read I can really only just issue a connect to Wifi command when the device is in listening mode. Ive done it from the Orenda App and my Laptop through NodeJs SoftAP … .still flashes Cyan so I can only assume its definitely a keys issue.

@ParticleD The Orenda support team has been pretty responsive to me but only on a support level. So i am not sure if they are actually sending information to the Dev team or what. They could be flat out lying just to prevent me from issuing a refund. They have really only given me scripted responses nothing specific to my device like asking what my Device ID is etc… Hopefully the Dev team is still alive and can actually fix this. Ive seen many posts threatening a Class Action Lawsuit.

@ScruffR I ve just asked Peter on facebook if there is a Hidden USB interface, if he responds with his details I may be able to fix this. I just dont want to take the whole device apart its tricky

I was refering to the red/orange blink that can be seen in the top one of your two posted videos.

Yes the Red/Orange only happened on a off chance. But consistently after Listening mode, setup WiFi it continues to flash Cyan. That Red/Orange could have been when I was trying different Wifi settings

You don’t happen to have a real Particle device at hand to check whether your router/firewall might be blocking the cloud connection?

Have you got the chance to test on a different WiFi network?

I do not have a Particle Device. Ive tried normal Wifi settings that all my other devices connect to. Wifi with Security turned off. Ive also tried Bridging a connection through my laptop. Ive tried Connecting the Photon to my wireless hotspot off my phone. Also tried it on a neighbors wifi. all of them result in Flashing Cyan lol

I am almost positive there is no USB connector inside the machine. That’s not to say that one couldn’t be added, depending on how the machine is constructed.

I’m wondering if there’s a JTAG or SWD connector in there somewhere… I don’t see anything in the pic but it could be obscured.

ParticleD

Consider that a ‘lean startup’ often works like this:

  1. Company has idea, has a small amount of funding or crowdfunding
  2. Founders realize they need help, seek out engineering resources
  3. Engineering resources require MUCH more money than originally imagined, either due to an extravagant features list or simple under-estimation of development cost.
  4. Product is delivered (hopefully!) but something has been traded: either quality or features (because there is no more money)
  5. No one is happy, the product is a sad echo of what it was supposed to be and the engineering team may not even be getting paid at this point.

Not that I have any insight into this situation in particular, but my guess is that there probably is no “dev team”.

4 Likes

Current Response.
@HEng If there is no further response then you are probably right

2 Likes

Perhaps not a USB connector but maybe just the USB connections (landing pads to make temp connections). I would expect those connections to be on the side of the P1 where the QC sticker is, possibly going through 2 low ohm resistors (22 ohm is typical). There is a plastic (?) part obscuring some components - most likely the decouple caps. Resistors and/or landing pads could be on the other side of the board.

Looks like one of the co-founders (Pawin Wongtada) has a mechatronics background: my guess is he is much of the engineering team