Offline programming using Ubuntu app doesn't seem to load correctly

I have been testing the particle commands offline such as WiFi.on(), WiFi.connect(), () etc. After I edit my app and upload the program to the photon it looks like the program it runs was the previous version of the app. It doesn’t seem to upload the most recent version. I ran a make clean on the photon and uploaded the firmware again but that doesn’t seem to fix anything. I was wondering if anyone else was running into a similar issue.

Is this Particle Dev you’re talking about?
If so, make sure to save your changes before flashing, as it won’t do that automatically.

No I’m just programming from the command line using ARM GCC and DFU

What is your exact build command, from which path are you calling it and which binary are you flashing?
What branch are you on?

I’ve been following the sparkfun tutorial and using the firmware form here So I created an app called blink in firmware/user/application/blink. In that file right now I have:

1 #include "application.h"
2 void setup()
3 {
4 }
6 void loop()
7 {
9 }

However, this isn’t working. Its running an older version of this blink app that I erased.

To program is i go into firmware/main then run: make PLATFORM=photon APP=blink program-dfu
everything flashes correctly but the program running on the photon doesn’t behave the way I expect. I used the online IDE to check how the photon should react if I ran the program above and the behavior doesn’t match.

I fixed the problem it seems there was an internal error in the way I set things up. Everything is working now.
Thanks for the help

1 Like