Official Particle Android app is unable to see new Photon's


#42

@ido, will v2.0 allow to enter a custom SoftAP SSID too?
Currently I have tested 7 phones (2x Windows 10, 5x Android v4, v6, v7) and could not reclaim a previously owned device, temporarily transfered to a dummy account.

Windows didn’t try to reclaim, Android v4 did try but the app crashed on that step, in v6 & v7 the app wouldn’t even see the Photon-WWHH SoftAP although the phones WiFi would see and connect to it.

Adding a means to just select any visible SSID as potential SoftAP should help circumventing this roadblock - even for devices that got reprogrammed SSIDs.

And since the mobile apps seem to be the only way to force-claim a device, the hardware agnostic setup.particle.io path seems out of the picture too.


#43

We’d love to get a breakdown on the exact android versions and hardware type experiencing this problem of not seeing the Photons SSID in the setup list.
Also can the phones that experience this issue see the photon’s SSIDs in the normal wifi connection list in phone settings?
How many photons were online (give or take) when this issue was arising?
Is it consistent - meaning those phones NEVER see any photons or sometimes they do?

@ScruffR I am not sure why would adding all SSIDs around the phone to the list would be helpful - it would just cause more issues/timeouts when users will choose a non-photon device. No reason for the phone not to see photon SSIDs.


#44

@ido, thanks for the reply, but having another SSID than Photon-xxxx does not mean it can’t be a Photon device.
I would not have proposed this if there wasn’t a valid reason for this.

I also didn’t suggest the app should display all SSIDs it sees, but allow for the user to enter a custom SSID (or select from a list which could be displayed on demand only) just in case the app can’t find the Photon based device (be it for any obscure reason, as the topic here well illustrates or since the owner decided to change the Photon’s own SSID).

Even worse then that I have three Android Phones where the app doesn’t see the one and only active Photon-xxxx SoftAP (but that’s irrespective which of my Photons I try).
Huawei Mate 8 (Android v7)
Huawei P10 Lite (Android v7)
Samsung Galaxy S5 (Android v6)
But as said above, the Phone itself can see the SoftAP and connect to it.


#45

I use Particle in class twice a year currently. I’ll do this again in about 3 months so i’ll post some data then?

My personal phone also has this problem. It’s a Galaxy S5 that can see and connect to both the Photon and my custom P1 modules without the app. I just can’t see them when using the app. Enclosed is a picture showing details about my Android version.


#46

On those devices where app doesn’t see Photons, could you check if location/gps is enabled or not? I have tiny feeling that might be the issue.


#47

Not enabled


#48

Hi all,

Would it be fair to say that, until it is resolved, this issue will impact on anyone who intends to start selling a photon-based product reliant on the android app? What is the confidence level that it can be fixed?

Cheers,

Al.


#49

Released a fix on setup library 0.4.7
This version should enforce user to enable gps/location service as it is needed to go around bug in Android M and later versions.

Fix included in upcoming v2.0 app.


#50

I would not rely on the Android app. GPS is not relevant from what I can see? Why would you need GPS permissions to access network info?

setup.particle.io from a PC works well though.


#51

Location services are relevant and required because of this Android bug.


#52

Dang… I just set up 3 new PCB’s with P1 modules today. Should have tested with Location turned on.

Gotta say that is a rather grave bug if that’s the cause! Really sloppy coding from the Android Team?


#53

Technically it’s not even a bug, it is “intended behavior”. Due to possibility to determine user location based on wifi Android team decided to force location to be enabled.
They choose to go with until recently undocumented behavior of returning false/empty readings - only existing workaround is to break user experience forcing user to exit application and enable location services in settings.

So it’s even worse than sloppy coding.


#55

Just soldered up and setup 6 new boards and just like @julius says - it works if I enable location. Annoying move from Google…