No USB serial connection

I’m using an E402 module and after PCB assembly my computer doesn’t recognize the device when it gets plugged in my computer’s USB port. They always show up in Device Manager as an assigned COM number.

Usually in the past, I"ve had to reflash the boatload via SWD to regain functionality. But on 17 devices I have, I’m able to reflash the boatload via SWD but the devices still are not recognized by my computer.

I am wondering if anyone has any suggestions so that the serial connection will be recognized? IE would erasing all memory blocks work?

image from :

Can you show a screenshot of that?
By the verbal description this sounds rather normal to me :confused:

Is the device not showing up in DFU mode or regular operating mode or safe mode? DFU mode is implemented in the bootloader, but USB serial (CDC) is implemented in Device OS, so that’s dependent on the Device OS version. If you are in DFU mode you would normally not see any CDC serial port.

The devices normally show up in regular operating mode as below.
I have 16 devices that do not and I’m unable to force them into Safe or DFU mode using the mode button. Even after reflashing the bootloader, the devices do not connect to the com port. I can still read and write to the memory through SWD.


these are the devices all showing the same behavior

Can you probe pin D7? If the pin is high, then the device is either running the bootloader (possibly in DFU mode) or can’t boot that far and the STM32 is sitting in halt mode. If the pin goes high briefly and then goes low, then Device OS has probably booted.

In addition to flashing the bootloader, you may want to flash a restore image instead. This will not only flash the bootloader, but also Device OS and Tinker, which will rule out a problem with one of those things.

D7 stays high, I’ll try the restore image.

Restoring the image with the below worked.


1 Like

@rickkas7 I’m trying to release the security bit for a device, I have the device in DFU mode and using the Paricle debugger with openOCD installed.

I tried running the below command but got an error. Do you know whats wrong?

I’m able to get the version of openOCD as below

Remove the \ from the middle of the command. It was there for line wrapping continuation, but since you’re already one line it can’t be there.

@rickkas7 ok I got it mostly working now, but not when I Connect the Debugger to the device with SWD as in the instructions. i get the below error. the Device is in DFU mode, and not really sure what else to do at this point.

You can clear the flash write protection bits from ST-LINK, and that seems like it’s working for you.

It’s in the Target menu, Option Bytes, then click the Write Protection button in the Flash Sector Protection area.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.