No DFU capable USB device available?


#1

I don’t know if this is a Workbench-specific issue, but that’s where I’m seeing it: when I try to flash locally, I get

Suffix successfully added to file
Serial device PARTICLE_SERIAL_DEV : not available
Flashing using dfu:
dfu-util -d 0x2B04:0xD006 -a 0 -s 0x80A0000:leave -D /Users/me/…/Expendable/target/Expendable.dfu
dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2016 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to http://sourceforge.net/p/dfu-util/tickets/

dfu-util: No DFU capable USB device available
make[2]: *** [program-dfu] Error 74

Any info would be appreciated. I could’ve sworn I got this to work, at work, without any difficulties …


#2

Assume that the device is in DFU mode!

Have you tried running the DFU utility outside of the dev environment? Or particle cli flash command?


#3

@UMD is right - did you put the device into DFU mode? A device won’t automatically enter that mode. Instructions can be found here.


#4

That solved my problem, thanks, gentlemen. I hadn’t used dfu-util much, if at all (a testimonial to how well-engineered the Photon is), and since Particle: Cloud Flash just took a couple of keystrokes, I figured Particle: Flash Application (local) would work exactly the same.


#5

Are there plans to implement this feature into Particle workbench? All that is required is to set the serial baud rate of the device to 14400.

I’ve done this with po-util and it really speeds up flashing time when the device is put into dfu mode automatically.


#6

And as the poster child for why this is needed, I’d like to second this request! :grinning: