[Local Cloud] Can't compile locally via the local cloud

Each time i try to compine a directory or just a ino i got this error message. What am i missing ?
Note : I am just copy pasting my code from the cloud ide and verifying code to work perfectly .

Gentmats-MacBook-Pro:~ gentmat$ spark compile /Users/gentmat/Desktop/maroun --saveTo firmware.bin
attempting to compile firmware
pushing file: /Users/gentmat/Desktop/maroun/app.ino
Compile failed -  compile failed

Try spark compile app.ino

Tried that already ! that doesnt work either same error

code inside app.ino is simple exemple

int led = D0;  
int led2 = D7;

void setup() {
  pinMode(led, OUTPUT);
  pinMode(led2, OUTPUT);

void loop() {
  digitalWrite(led, HIGH);
  digitalWrite(led2, HIGH);
  digitalWrite(led, LOW);   
  digitalWrite(led2, LOW);

That’s weird. I just tried and it is working.

Can you check the spark.config.json file and make sure you don’t have apiUrl

I have my local ip address , as you did it local cloud.
so i cant use compile if i am running a local cloud ?

Right now, compile is not available on local :cloud: :smiley:

I ll parse it from web then . see why java is here :stuck_out_tongue:
it will be done in 1 hr more :d

Done but i prefered the local compile. @dave is there gonna be an update soon for the compile command to work out ? i read that its on the list . any time soon ?

Hi @Gentmat,

We’re thinking about this down the road, but I think probably not in the next few weeks. If you’re working in the build IDE you can click the “Download” icon by the project name to download your firmware binary, and flash it via your local cloud with spark flash your_core binary.bin You can also setup a local build environment using the guide here: https://github.com/spark/core-firmware