LiquidCrystal_I2C_Spark.h: No such file or directory in Build IDE

Hi,

I’ve imported the “LiquidCrystal_IC2_Spark” lib using the Build IDE. I can see just before I hit “Include in Project” there are two files, LiquidCrystal_I2C_Spark.cpp and LiquidCrystal_I2C_Spark.h

The following is then automatically added to my code…

// This #include statement was automatically added by the Particle IDE.
#include <LiquidCrystal_I2C_Spark.h>

But when I try to verify I get:

fatal error: LiquidCrystal_I2C_Spark.h: No such file or directory

I’ve found some older forum posts about his but they all either seem to suggest issues with older versions (2016/2015) or problems cause by people not downloading the lib files… I’ve not downloaded anything, I’ve just been using the Build IDE.

I’ve tried deleting my code and recreate (an older post from 2015 said this may work) but no luck.

Any help would be appreciated.

Thanks

Potentially related, the second lib I tried to import (HttpdClient) using the Build IDE gave the exact same error…

HttpClient.h: No such file or directory

Is there something I need to do after importing using the IDE? Perhaps I’m missing a step.

As usual these questions

  • which device are you using?
  • which device OS version are you targeting?

This builds fine for me (using Photon v1.1.0)
https://go.particle.io/shared_apps/5d07cfbbf6a87b000b152114

I copied your app, hit Verify, and it failed.

I’m using an Electron on 0.4.8.

Thanks

That is most likely the issue - don’t use a firmware that’s many years old.
With some 0.5.x version the library structure has changed.

3 Likes

Thanks, ScruffR… update the firmware to the latest 1.2.0 has resolved these import issues.

1 Like