Library upload broken? [CLI 1.19.0-libraries.22] [was solved v23, but back in 1.19.1]

@jvanier, the example building did work, but now I’ve got another problem

Although I could use most of the other particle library commands, I seem to be unable to upload

C:\Users\Andy\Dropbox\DokumenteAndy\Particle\RGBAnimation>particle library --help
Usage: library <command>

  add      Add a library to the current project.
  init     Initializes a new library in the specified or current directory.
  copy     copies a library to the current project
  list     Lists libraries available
  migrate  Migrates a local library from v1 to v2 format.
  search   searches available libraries
  upload   uploads a private version of a library
  publish  publishes a library

Global Options:
  -v, --verbose  Increases how much logging to display                   [count]
  -q, --quiet    Decreases how much logging to display                   [count]

C:\Users\Andy\Dropbox\DokumenteAndy\Particle>particle library upload RGBAnimation --dryRun
particle: Unknown command: "library"

Apparently upload causes CLI to have amnesia and even forget about library which was still known a second ago.

But when I do this

C:\Users\Andy\Dropbox\DokumenteAndy\Particle\RGBAnimation>particle library upload

I get

Library is not valid. 
main source is missing
main header is missing

despite the fact that there are RGBAnimation.cpp and RGBAnimation.h present in src and RGBAnimation is the name of the library in

What exactly am I missing? A more elaborate info would be nice :wink:

Thanks for the note, @ScruffR! @jvanier should be back in the office from his holiday vacation starting tomorrow!

1 Like

Hi @ScruffR, I fixed the validation issue on Windows. I’d love if you could try again.

npm install -g

Upload succeeded this time - have to check if everything works as expected now :+1:

Building the example that also requires secondary libs works quite well.
The only thing I was a bit puzzling in Build-Canary is that the Save button :file_folder: is not highlited but grayed out.


@jvanier, I’ve just tried to particle library upload a migrated lib and got this for it on CLI 1.19.1

$\Particle\Adafruit_HX8357>particle library upload
Network error from

That used to work with 1.19.0-libraries.23

Strangely enough I was able to upload another (smaller) migrated library just fine, but this one doesn’t want to be uploaded for some reason

I found the reason. One of the examples brings a 450KB demo bitmap along and hence the upload fails. Removing that file allows the upload, but then the demo is only worth half, since the displays wants a R5G6B5 bitmap which not every user may know how to produce one, just for the sake of running the sample.

1 Like

@jvanier @suda are there any size limitations (intentional or otherwise :wink: ) on library size?

I’ll need to check and get back to you on what’s going on. That’s the most complex example I’ve seen so far: dependencies on other libraries and a bitmap.

You haven’t seen my Nextion library yet :wink:

BTW, is there a way to retract an uploaded but not published lib?
I’ve by accident uploaded with a too high version number.

No there’s no way to delete a private library version at this point. It’s an improvement that we plan on making.

1 Like

I’m trying to upload a library but after 2-3 minutes of loading, it stops with Network error from I tried removing example files to decrease its size but it doesn’t work.

Hi, and welcome to the community :grin:

Firstly please :pray: don’t double the posts

As this will not help.
Let me try to ping some Masters
@m_m @nrobinson2000 @rickkas7
Do you guys can help ?
Any idea what can be wrong?
Thanks in Advance !

I think in this case it’s better to continue the discussion in a new post, rather than a thread from 5 years ago. I’ll take a look soon, but I suspect this error is from using nvm rather than particle-cli-wrapper.


Yes I can confirm it’s something to do with nvm. I installed particle-cli in non-nvm npm and tried uploading and it worked.