Issues with Particle Shield Shield

I recently received the Particle Shield Shield and after putting it through some tests I don’t believe that it is performing as it should. Issues that I am experiencing include the Shield Shield’s 3v3 pin not outputting any voltage and the voltage conversion not being correct.

For example, a 5V source into the Shield Sheild’s Analog pins translates to more than 3.3V (3.542V) to the header pin for the photon’s ADC. I also tried putting a 3.3V source into the Shield Shield which if I understand correctly should result in 2.178V output (3.3V/5V=0.66*3.3V=2.178V). I’m showing an output of 0.283V. Do I have a defective unit, or am I misunderstanding the capabilities of the Shield Shield?

What if you try powering it from the barrel jack?

I’m powering the Shield Shield through the barrel jack with a 12V AC adapter (800mA). I’ve avoided plugging my photon into it’s headers on the Shield Shield due to the 5V input resulting in a voltage translation greater than 3.3V. I don’t want to do any damage to the photon’s ADC.

Where did you try to feed that 3.3V into?
Your calculation would assume you’re dealing with a voltage divider or similar, but the “voltage translation” from the dedicated supply terminals to the supply rails for the shield components are done via converters (on Shield Shield a voltage regulator - others use buck converters) that require a minimum voltage to work and I’d assume (since no info about the feeding point is given) 3.3V is too low for them to work at all.

What meter are you using?
Where does the signal come from that translates to 3.542V?
Which Analog pins are you feeding your 5V into?

This might be interesting to look at
https://github.com/spark/shields/blob/master/photon-shields/PDFs/Schematics/shield-shield-v301.pdf

For my source I’ve been using an arduino UNO using it’s 3.3V and 5V pins which were measured to be accurate. The output of the arduino was then inserted into the A0 pin of the shield shield. I then measured the voltage off of the photons headers (A0, and ground) to get my results. I tried A1 as well with the same results.

Here is a diagram of my setup. DMM is a Fluke 115:

Measuring between the Shield Shields pins 3v3 and GND reads 0V so I feel like something has to be wrong with this thing.

@crazedwombats, looking at the shield-shield schematics, A0 and A1 of the Arduino connector is clamped by a 3.4v zener diode coupled with a 150 ohm resistor to limit current into the A0 and A1 pins of the Photon. The same applies with the DAC and A3 pins of the Photon.

So, if you put a 5v level on the pin, the zener will clip the voltage to what you are seeing. The take away here is that the zener provides protection, not conversion so if you expect a 0-5v level to be nicely converted to a 0-3.3v level, the circuit is not designed for that. The balance of the Analog pins go through a logic level translator to be provide 5v SPI compatibility.

1 Like

To add to what @peekay123 said, in order to feed a voltage from one device into another, you need to connect both grounds (common ground), but I’m not seeing that connection in your schematic.

Could you also show these connections and do you have the Photon inserted when you do your tests.

I also doubt that the 3V3 & 5V pins on the shield headers are meant as inputs.