Issues with device-hosted SoftAP


#1

Hi!

One way that customers claim their device through our webapp is connecting to a HTTP page hosted on their device. This device-hosted page then runs through a claim flow that interacts with the SoftAP. It has generally worked well and will successfully claim the device, add the customer to our product, and connect the device to WiFi.

Recently, however, we tried the claim flow on a new computer, and were unable to connect to the device-hosted server on that computer. When we went to http://192.168.0.1/ in the browser was unable to connect.

We then tried a different approach, connecting to the device through the browser, but with a downloadable local file, the same approach used in setup.particle.io. With this approach, we were able to connect to the SoftAP. We were also able to connect to the device’s SoftAP via curl commands on the command line.

This was consistent across browser. The computer that we used was a Macbook Air, OS X El Capitan, Version 10.11.2.

I had seen in this thread that the SoftAP has experienced issues on different devices before, so this doesn’t seem unprecedented. After reading that thread, however, I’m not sure how to approach debugging this.

If it helps, the softapp code that we are currently running on our device is compiled using the compress.py script in my fork of the softap-setup-page repo. Perhaps the rsa files I’m using are out of date?


#2

I think the method is getting more difficult as device OS’s insert more routines into WiFi connections etc that check if the internet is accessible and bail if it isn’t.


#3

Could you say more about this? Are you saying that OS’s are throttling the browsers connection via the browser? If so, do you know if there is a way of knowing which combinations of OS, device, and browser will lead to difficulties?


#4

One of the reasons I found with devices (especially iOS) that won’t connect to the SoftAP is their refusal to connect to a network that does not also provide connection to the internet.
Since I have no iOS devices myself I wasn’t able to find the setting to change in order to lift that restriction, but I’m sure there must be one.


iOS 12 SoftAP can't connect to p1
#5

@gemfarmer This above rings the bell. I experienced this same thing on an Android phone few weeks back.
The popup on my phone showed something like this (copy-pasting the image from the internet):

ONLY when I answered YES I was able to connect to my photon with the softAP on.


iOS 12 SoftAP can't connect to p1
#6

I have been playing with this a lot recently and it is not an issue I have ran into with the Photon Soft AP. iOS throws up ‘No internet connection’ warning at first but has no problem connecting. MacOS also connects just fine in my experience.
I do recall older iOS versions <10 did not handle it very well, especially if there was another known network available as it would swap to the known connection.


#7

Based on all of your replies I’m going to assume the issue that we were experiencing is pretty fringe. We have since been able to connect on that computer, but intermittently (almost more annoying).

We’ll encourage people to try on a different device if they run into these issues.

Thanks so much!


#8

@gemfarmer, @gusgonnet, this sounds like one and the same problem as listed here: Android 7.1 and SoftAP


#9

Hi Harry, yes, they look the same. Thanks for the link.
Gustavo.


#10

Yes it is. Thanks @UMD!