Issues transferring device ownership

I’m switching a photon from my personal account to my business’s account and having issues transferring ownership.

On my personal account, the photon was listed as a product device. I removed the device from the product and also ran particle device remove [device_id] from the particle CLI. There was nothing to remove, but I ran it just to be safe.

Then, I tried adding the device in the Particle Console. This didn’t work and I got this error:

Bummer! No devices were added to your product. Please double check the device IDs are correct and try again.

The device was connected to WiFi (breathing cyan) and the device ID was valid. Am I missing a step here? I feel like I’ve followed all the steps listed in the guides and on this forum.

It’s not necessary or really desirable to remove a device from a product to transfer ownership. You would normally Unclaim Device but not Remove Device.

You only need to Remove Device if you want to switch it to being a non-product device, or to move it to a different product.

That being said, you should submit a support ticket with the device ID and product ID so the database and logs can be checked to see what actually happened.

1 Like

I will file a ticket!