Issue with using Core in a new Sparkfun Battery Shield

When I followed the instructions, I got that I was running system firmware version: 0.4.4

When I uploaded this last time, instead of selecting Latest (0.4.5) I selected 0.4.5. That seems to have done the trick. It flashed magenta for a while, but when it came back up I was getting legit values for SOC.

I’ll be seeing if my reliability has problems like others are reporting, but I am set for now! Thank you!

I have been out of town, but when I got back and did a web IDE reflash, it’s been giving me correct info, even as I plug and unplug it from USB. I would like to get more than a few hours of data to say conclusively that it’s stable, but it definitely seems to be more stable.

The reflash seems to have broken my IFTTT recipe that wrote this monitor info to a Google Spreadsheet, though…

IFTTT seemed to have lost its authentication to Particle randomly (all recipes failed,) so that was an easy fix. Curious as to what triggers that, but I bet it is on their end.

Thus far, battery reading seems solid with current firmware. I have another issue I’ll start a separate topic for.

@gelicia Any further issues from you? If not I think we can close this.

Yep, I’m good now. Thank you to everyone who helped me out :slight_smile:

I’m not having the same problem exactly, but I am getting weird values for my SOC. I am just publishing the value to a Google spreadsheet but the raw values currently are 1,079,406,592.00. It goes up while charging and down when unplugged so I believe it is working, but just not sure why the large number. I am using a photon with the newest firmware. Anyone have a thought?

I am having this problem now, and I am using firmware version 0.6.0…
Does anyone have any suggestions? I’m thinking of flashing using version 0.4.5 but I don’t think that will be a long term solution, assuming it even works.

Thanks in advance.


I’m a new Photon and Shield user. I have done some testing
with good result and now i run into the exact same problem.

My firmware is the last 0.6.1.

Does anybody have a solution to this problem ?


I experienced this problem as well. Batt voltage consistently showed 5 v (no drop over time, even at night) and SOC indicated 255. All other data (temp, humidity) was crazy as heck (this was part of a weather underground station that I built). I tried unplugging everything, esp the battery, and reassembled. No luck. However, I remembered that I switched the Photon on this configuration out a few days ago after I screwed up some code on the original board.* Once I switched back to the original Photon, everything worked again. I thought that, perhaps, the boards were different versions (PHOTONH vs. PHOTONNOH), but they were both PHOTONH. I couldn’t find any other revision numbers…

*I programmed in a deep sleep for several minutes during each cycle without sufficient delays built in. The problem? I couldn’t flash the darn thing OTA to update code. After trying to install Particle CLI on Mac (a disaster), I installed it on an old, old laptop and completely flashed the photon. No amount of soft reset, etc., would work.

Hi everybody.

I’ve just faced with the same problem. Dear Particle, do you have any answer to community?