Issue with GY-BME/P280


#1

Dear Community,
I thought I could acquire a clone from the BME280 and got a GY-BME/P280.


Already the name of the sensor made me wonder: did I have an E or a P in my hand now? Which Libary was the right one: I tried different libaries, but without success.

In order to exclude wiring problems, I concentrated on I2C: without success.

I get no values in the serial output. Tested with 0xD0, 0x76 and 0x77. When I2C scanned no address, I switched to SPI.


With hardware SPI I had tried the following wiring, without success:

#define BMP_SCK A3  // > SCL This is the SPI Clock pin, its an input to the chip
#define BMP_MISO A4 // > SDO this is the Serial Data Out / Master In Slave Out pin (MISO), for data sent from the Sensor to your processor
#define BMP_MOSI A5 // > SDA this is the Serial Data In / Master Out Slave In pin (MOSI), for data sent from your processor to the Sensor
#define BMP_CS A2   // > CSB this is the Chip Select pin, drop it low to start an SPI transaction. Its an input to the chip

It ended in breathing Photon white.

Can you breathe life into the sensor?


#2

That board is really tiny. Are there resistors on the other side?

If not, to use I2C mode you probably need to connect CSB to 3V3 and put a 4.7K or 10K pull-up resistor from SDA to 3V3 and another from SCL to 3V3.

Then try the I2C scanner.


#3

Thx for feedback, Rick: yes, the breakout is tiny like the dimension from “fn”-key.


On the backside are resistors: have yet again tested with additional resistors and also connected CSB with 3v3.
Also used another Photon with this wiring without getting values:

// I2C wiring
#define BME_MOSI D0 // = SDA Photon PIN out diagram
#define BME_SCK D1  // = SCL Photon PIN out diagram

// CSB = Chip Selector = https://community.particle.io/t/adafruit-bme280-library-ported/15826/36?u=postler to 3V3@Photo
// SDO not in use

Here some better pics from the seller.


#4

@Alli and @ScruffR I got the same problem like this guy @Postler was troubled by, with the same sensor. Now one of my photon is blinking green and another one white. I had tried @Alli code with some other codes and libraries too, but no fortune.
Anyway thanks for your help.