Issue Disabling Optimization When Debugging in VS Code / Particle Workbench

Good afternoon!

Im having an issue where Visual Studio Code and Particle Workbench wont allow me to add #pragma GCC optimize (“O0”) to my source file without throwing an error upon debugging:

“Error exists after running preLaunchTask ‘Particle: Flash application for debug(local)’.”
The process terminates with exit code: 2.

When I tell it to “Show Error”, it takes me to one of the warnings that weren’t a problem before:

Adafruit_SSD1306.h lib\Adafruit_SSD1306_RK\src
“SPI_HAS_TRANSACTION” redefined gcc [41, 1].

This is part of the oled-wing-adafruit library.

I wanted to disable optimization (couldn’t see many of my local variables as they were “optimized out”), but as soon as I add #pragma GCC optimize (“O0”) it fails with the above error.

I tried to replicate the error using the TinkerBreak example in the debugging tutorial (includes the “O0” optimize code), but it did not cause an issue. I also tried deleting the examples folders from the various adafruit libraries, to no effect.

Any insight would be appreciated.

-RC