I can't get Spark CLI to work on my Windows 8 Machine

Can you paste the output for npm install spark-cli --verbose ?

1 Like

Can you make sure that the command prompt is running as Administrator when you do the npm install -g spark-cli?

1 Like

@rblott,

please stop. I’m not referring to that. :smile:

I mean just use npm install -g spark-cli like i mentioned. What happens after? Did it install properly with the command prompt which is running as Administrator?

does spark login work after that?

The screenshot shows that the node.js command prompt is running as Administrator

However, I would recommend, that if you platform is 64-bits that you install the 64 bit libraries. I have 8.1 64-bit running okay

Your environment has been set up for using Node.js 0.10.29 (x64) and npm.

From: https://www.npmjs.org/package/serialport - edited

To Install
Windows 7 or Windows 8.1 are supported.
Install Visual Studio Express 2013 for Windows Desktop.
Install node.js 0.10.x matching the bitness (32 or 64) of your operating system.
Install Python 2.7.6 matching the bitness of your operating system. For any questions, please refer to their FAQ. Default settings are perfect.
Open the ‘Visual Studio Command Prompt’ and add Python to the path.

I’m running full fat VS2013 Ultimate - pretty cool you need VS to access the serial port :-/

Hi @albal,

We’re using the Node Serialport module ( https://github.com/voodootikigod/node-serialport ). They have compiled binaries for most platforms, but I think they are working out some issues with some versions of windows.

Thanks!
David

Hi @albal
Thanks for your help. Using your notes this is how I am getting on, in bold

The screenshot shows that the node.js command prompt is running as Administrator
However, I would recommend, that if you platform is 64-bits that you install the 64 bit libraries. I have 8.1 64-bit running okay I have 8.1 running fine, too
Your environment has been set up for using Node.js 0.10.29 (x64) and npm. Done that: now have Node.js 0.10.30 (x64)
From: https://www.npmjs.org/package/serialport
I followed the instructions from the link and in node.js command prompt (Admin mode) I typed “npm install serial port”, it took forever then came up with my old favourite:

To Install
Windows 7 or Windows 8.1 are supported.
Install Visual Studio Express 2013 for Windows Desktop. Done that
Install node.js 0.10.x matching the bitness (32 or 64) of your operating system. Already done that
Install Python 2.7.6 matching the bitness of your operating system. For any questions, please refer to their FAQ. Default settings are perfect. Done that, too
Open the ‘Visual Studio Command Prompt’ and add Python to the path. Not sure what this means/how to do it!

The real mystery is why I don’t seem to be able to load this serialport thing.

Thanks, again.

1 Like

@rblott

I meant I have spark.io working on my Win8.1-x64 system at work - not generally that my win 8.1 is fine :smile:

Okay so I am on another windows x64 intel box, but I am afraid it has full fat VS on it but it didn’t have node. So I used this link:

http://node.js/
and the download button gives this binary:
http://nodejs.org/dist/v0.10.30/x64/node-v0.10.30-x64.msi

Install that with a next, next, finish approach. Ran up the cmd as administrator and ran the spark-cli install:

Your environment has been set up for using Node.js 0.10.30 (x64) and npm.

C:\Windows\System32>npm install -g spark-cli

serialport@1.4.5 install C:\Users\User\AppData\Roaming\npm\node_modules\spark-cli\node_modules\serialport
node-pre-gyp install --fallback-to-build

[serialport] Success: “C:\Users\User\AppData\Roaming\npm\node_modules\spark-cli\node_modules\serialport\build\serialport\v1.4.5\Release\node-v11-win32-x64\se
rialport.node” is installed via remote
C:\Users\User\AppData\Roaming\npm\spark -> C:\Users\User\AppData\Roaming\npm\node_modules\spark-cli\bin\spark.js
spark-cli@0.3.97 C:\Users\User\AppData\Roaming\npm\node_modules\spark-cli
├── xtend@4.0.0
├── when@3.4.3
├── hogan.js@2.0.0
├── request@2.40.0 (json-stringify-safe@5.0.0, aws-sign2@0.5.0, forever-agent@0.5.2, tunnel-agent@0.4.0, oauth-sign@0.3.0, stringstream@0.0.4, mime-types@1.0.2,
node-uuid@1.4.1, qs@1.0.2, tough-cookie@0.12.1, hawk@1.1.1, form-data@0.1.4, http-signature@0.10.0)
├── moment@2.8.1
└── serialport@1.4.5 (bindings@1.2.1, async@0.9.0, nan@1.3.0, sf@0.1.7, optimist@0.6.1)

C:\Windows\System32>spark cloud login
Could I please have an email address?

It took a few seconds though not ages, are you behind a proxy or have a very picky anti-virus and/or firewall turned on. Perhaps try to disable that during the install part?

Hopefully, that would be it. If that does not work post back the output (as admin):

npm install -g serialport --verbose

p.s. Spark - don’t override browser key combinations for your own UI purposes (very annoying to have to go into my browser UI to do page text search) - Ctrl-F, how very dare you! :wink:

OK, will try all that again. There was one thing that I didn’t get from your earlier response:

"Open the ‘Visual Studio Command Prompt’ and add Python to the path. "

What does this mean - what do I need to do. I don’t know where to find the VS Command Prompt…

As for my Firewall - it is a bit zealous. Anti-virus is Norton…although I seem to have lost the Norton Manager to see what it’s up to.

BR
Roger

Hi Dave,
I read this in the serialport install document at voodootikigod
"Open the ‘Visual Studio Command Prompt’ and add Python to the path".
How does one add Python to the path? I have worked out how to open the VS Command prompt (should I do this in Administrator mode?).
Thanks,
Roger

Hi @rblott,

Good question! The PATH is the list of folders that windows will check to try and find something like Python. There’s a tutorial on how to change it here:

http://geekswithblogs.net/renso/archive/2009/10/21/how-to-set-the-windows-path-in-windows-7.aspx

Thanks,
David

High @rblott,
having the same problem as you do have (had?) the solution for me I did find here:

As discussed I somehow had managed to get “C:\Windows\System32” out of the PATH variable. Thus VS did not work: Adding C:\Windows\System32 to the Path variable everything suddenly works!!

Regards Walter

That fixed it for me. I was experiencing the same error (‘particle’ is not recognized as an internal or external command) and I had to go to this dir (C:\Users<username>\AppData\Roaming\npm) in my normal command prompt and there I was able to user the “particle” command. Thanks a lot for all the info on the page!