I can't flash code to my Boron Device when it's connected to computer by USB

My Boron LTE is connected to cellular supposedly because it’s breathing cyan, but I can’t flash code to it when it’s connected to my computer for some reason.

I’m trying to read the serial output from my Boron device because I want to connect it to my adafruit accelerometer and the demo code I’m using outputs to serial. So I need the USB connection to read the serial monitor. If anyone can suggest a better way to play with this demo file, I’m open to suggestions.

This is the accelerometer I’m using.

This sounds like two separate issues to me. The first is flashing code. I see this is the first time you’ve posted, so I’m assuming you’re new to the platform. Have you read the docs on flashing firmware? Via USB, the device needs to be in DFU mode (flashing yellow) before you can flash over USB.

The second issue the serial monitor. We’ll need more details on what you’ve tried, and what results you’ve gotten to help further on that. Also, please post your code.

@picsil, OP has posted a link to his code.

Thanks. I saw that after I posted.

I don’t see anything obvious in the code that would cause no output on serial. From experience, you should expect a few seconds delay before you can write to serial in setup(), but that might vary. I only use SYSTEM_MODE(MANUAL).

I read how to put my device in DFU mode here but for some reason it doesn’t blink yellow for more than a second or two. Also, should it be blinking yellow while I’m flashing from the web IDE?

For posterity: the following commands solved my problem

particle update
particle flash --usb tinker


My favorite commands of all time. :slight_smile: