HttpClient - connection failed (ubidots)

Thanks @Hootie81. I will try the updated HttpClient.

Hi ubidots states this variable is empty initial don’t have this issue.

I am using this library and stated my problem on it’s thread as well as another thread. We have traced it back to this library for sure but get certain amount of intermittency.

I also have the client failing and timing out. It starts JUST failing then after ? cycles it does function but times out.
In my example it is talking to a web service which is constantly online. The failing stops between 1-5 cycles no link found for cycle number. Once it begins timing out the web service is working perfectly and the response is seen by the client it just seems to hold the connection open for no reason.

I have not tested my idea yet but I am wondering if it is line 190 in the library.
Instead of available may need to be connected?
Thats my plan anyway.

Hi have you tried your plan.

Yes that is not the problem. The issue continues even with combinations of them.
I have created a new web service to accept time out scenarios and publish swathes of data instead of just little bits. This is obviously not desirable because the library should work but has hiccups (its a new library so thats expected).

Have a look at this post, the library has been updated to disconnect after processing the correct number of bytes based on the content length header. Haven't tested it myself yet...

@itayd100, @twfinmv, Do you have an update on using the faster HTTP client mentioned in the above response by @Hootie81?

Sorry but I don’t have an update. My project has been sidelined by other non-particle work.

@TheVelozGroup,

I saw you asked today and I tried to install the lib on the Core and the Photon.
The Core worked well with the old lib, but with the new lib I have a problem. It can’t work with large answer:
HttpClient>.Error: Response body larger than buffer..
After a large answer the Core is stuck with this message in a loop.

I wanted to try it with the Photon, but right now I have a bigger problem. The Photon stuck after it enters into the loop. The program that worked on the Core doesn’t work on the Photon.

I think I’ll stay with the old and slow, but working one.
Good luck