Help with Latching Solenoid Valve


#1

This isn’t strictly a Particle or Photon question, but related to other threads on this forum. I’m building an irrigation system for four tomato plants in flower pots. Based on advice on this forum, I am attempting to use a latching solenoid valve to reduce power consumption, with an eye toward making it solar powered. I am using this valve with four outputs so I can independently control the output to each plant.

It is my understanding that for this latching valve, I need to provide a 12V pulse of 30 ms (or greater) duration in one direction to open the valve, and in the other direction to close it. My circuit consisting of a Photon, some digital inverters, and some L293D motor drivers successfully provides the correct pulses. The problem is that when testing, the valve never opens. I can hear a little thud as it tries to open and again when it tries to close, but it does not actually open.

I know that this valve needs water pressure to hold itself open. According to the valve data it works with a pressure of 0.02 - 0.8 MPa. This pump claims a lift of 300 cm, which if I am not mistaken equates to 0.029 MPa, so it should be sufficient (though I have not actually tried to verify a 3 meter lift). The valve calls for a minimum current of 300 mA, and I am using a 2A power supply to power the valve and electronics (using this Pololu voltage regulator for the electronics).

The circuit is working as I expect, based on the oscilloscope images showing an opening pulse and a closing pulse. Is there anything else I need to do to successfully operate a latching solenoid valve?

Opening pulse:

Closing pulse:


#2

I’m kind of surprised that a 30 ms. pulse would be sufficient. Usually you need to apply power long enough for a complete off-on or on-off cycle, which would be 500 ms. from my best guess of reading the data sheet. That might not be the problem, I’m just surprised.


#3

This other manufacturer which has significantly better information than the low-cost valve I used states that the pulses are typically 20 - 50 ms, and too long of a pulse would make it fail to stay open. So the 30 ms claimed for my valve seemed typical.


#4

You’re right. I stand corrected. (I mixed up thinking about how a non-latching and latching solenoid valve works - I forgot about the permanent magnet in the latching one that makes it work that way.)


#5

While my experience is limited to standard solenoids, you may be putting too much stock in those little pumps’ head pressure. Try either rigging your valve to a regular tap/garden hose or using a cheap diaphragm pump (e.g. one of these), either will have more than enough head pressure to verify or rule that out as your issue.

Plus, diaphragm pumps have the advantage of being self priming. The little impeller pumps can be stymied by a decent air bubble unless there’s a fair bit of head pressure feeding them


#6

BTW - where did you dig up that valve? Really like it, something similar could be handy for a future iteration of my automated garden project(s).


#7

That’s an excellent idea. I’ll try that and report back.

I found the valve on alibaba.com just by searching on Google for latching solenoid valves. I had no idea that there were multiport valves; I had thought I would need four separate valves. This was the only one I could find with four outlets.


#8

It took a while for me to get a new pump and find time to get back to this project. But I tried with this pump and it still doesn’t work correctly. I also tried another approach. I am using L293D motor drivers to provide the 12V pulses. Previously I was using the Enable pin of the L293D to enable the outputs only during a pulse, then disable them (high impedance state). This time around I am keeping the motor drivers enabled all the time, so the outputs are always either high or low. The valve still behaves the same way doing it this way. In other words it just clicks as if it is starting to open and maybe a drop of water gets through, but it doesn’t fully open. Then it clicks when it is supposed to close.

Does anyone have any other ideas? If not, I will see if I can operate it as a simple solenoid valve, without the latching feature. Sadly it will use more power, but I really like the four-output valve style for this project.


#9

Check:

  • Correct coil type. There are ac and dc versions. Are you sure you have the DC version? There’s a difference.

  • Current. These take a fair bit. Are you sure that you’re able to supply the full 300mA? If this is battery powered, just having 12V open circuit does not ensure you’ll be driving the coils with a full 12V once the internal resistance of the battery droops the voltage.

This is a good situation to have some bulk capacitance on tap in the form of large electrolytics.


#10

The data on the linked page suggests it’s 3A (3000mA) and it is in deed 12VDC.
image

Also, since this pump only exposes two wires, are you sure it needs to be pulsed to work?
Althought there is little detail on that page, I doubt the pump expects anything else than 12VDC while it’s supposed to pump.


#11

I read 12V/36R =333 mA.

I also see 6 different versions each with its own coil winding. The coil resistances are the giveaway.

One way to check is to measure the coil resistance with a DMM.


#12

Hmm, I must have missed the coil resistance figure in the “datasheet” or the type plate of the linked pump
image

Or have you got one of these pumps at hand?


#13

I read this as a problem actuating solenoids. Not spinning a pump. But if the pump draws 3A and the supply is 2A, that’s an issue too.

Photos and a schematic would be a help here.


#14

I see, we are talking about different things - that explains a lot :wink:
But the lack of power in the PSU would definetly pose an issue

  • 300+mA Photon
  • 300+mA solenoid
  • 3000mA pump

vs

  • 2000mA supply

will just not fly.


#15

I assume you are pumping water from a storage container, since if you had a pressurized supply you wouldn’t need the pump. I’m curious as to why you need the valve?

I’ve build similar systems with 12V Solar Panel, 12V/7AH SLA battery, Photon w/ Relay,and a $20 water pump with 3/8" tubing. I can send you product links if it helps. I went through several combinations before I found one that I liked.


#16

Are you sure this valve uses latching solenoids? I don’t see anything in the link you provided that says it is. In the specs it says the “switch mode” is “AC and DC continuous”.


#17

On the link you provided, I’m not sure where I see it is a latching solenoid valve. Are you buying this configuration and then changing the solenoids for latching?


#18

Thanks for all the responses. I’ll try to answer all of the questions.

The pump is running fine. It’s the valve that’s the problem. Sorry I was unclear in my last post.

The data sheet specifies 36 +/- 2 ohms for the 12V DC version. I measure between 39 and 40 ohms for the four coils. Just a little high, but closer than the other versions (one is 25, and the rest are 75 or more).

When I upgraded to the larger pump, I also upgraded to a 5 amp supply.

Correct.

Currently I am using a system I built a couple of years ago with a pump and no valve. The output of the pump splits through a tee, then each line splits again through tees, resulting in four hoses in parallel to water the four plants. My wife (the tomatoes are hers) feels that the four hoses do not output equal amounts of water. I’m designing a new system, and one of the new features is individually controllable outputs. Hence the four-way valve.

This is an interesting question. On the vendor’s site it is marketed as a latching solenoid, and it specifies a “Pulse width” of greater than or equal to 30 ms. I take the existence of a pulse width to mean it is latching, because otherwise I don’t understand what a pulse width would be for. I notice now that the pulse width is not listed on the previous site I linked. I cannot find the four-way valve listed any more, but here is the similar three-way valve.
The valve I have looks exactly like the one pictured, but has absolutely no markings on it. I’m going to try operating it as a regular solenoid without latching and see what happens. That probably won’t happen until this weekend though.


#19

Success, of a sort. The valve is not latching. It operates if I drive it as a regular solenoid valve. I’m not sure now if I just misunderstood the description, or confused it with another valve, because the original link I bought it from isn’t there any more. But thanks, everyone, for the helpful suggestions and discussion.