GEN 3 WiFi Devices on Ubiquiti Unifi WiFi Networks

For anyone that may stumble across this because you cannot get your GEN 3 devices to consistently connect to a Ubiquiti Unifi WiFi 2.4 GHz network…

Disable the “BSS Transition - Allow BSS Transition with WNM” option on your WiFi network.
On Unifi Controller V6.2.26:

  1. Click the Gear Icon from the left NAV
  2. Select “WIFI” from the next navigation group.
  3. Select the network you are trying to connect to from the right pane and expand the “Advanced” options.
  4. I disabled all advanced options as they are not necessary for IoT but make sure the “BSS Transition - Allow BSS Transition with WNM” option is definitely disabled.
    Save your changes and reconnect your GEN 3 device to the WiFi network.

I have a mix of Photons and Argons in my environment. Some clients are using Unifi and some are not. Those clients using Unifi WiFi I was unable to consistently get GEN 3 devices to connect to (Photons are not affected by this issue apparently). After some digging I found the article on the Unifi Community below. I disabled the BSS Transition option and connections have been rock solid (for now).

Hope this helps someone!

Fast Roaming and BSS Transition with WNM | Ubiquiti Community

5 Likes